blob: f213bc3c3e9e884fb734324bb889e40ba0ed99a0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=5b8620d98e49772d95fc1d291c26aa79"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://libtool-tag.patch \
11 "
12
Brad Bishop96ff1982019-08-19 13:50:42 -040013SRC_URI[md5sum] = "72f36b87cdb478aba1e78473393766aa"
14SRC_URI[sha256sum] = "cbc9102f4a31a8dafd42d642e9a3aa31e79a0aedaa1f6efd2795ebc83174ec18"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16inherit autotools lib_package
17
18do_configure_prepend () {
19 rm -f ${S}/conftools/libtool.m4
20}
21
22BBCLASSEXTEND = "native nativesdk"