blob: ffb1d061c0410a275569e995925394d3afbaa778 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
4SECTION = "console/network"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005# GPLv2+ (<< 3.0.0), GPLv3+ (>= 3.0.0)
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009DEPENDS = "popt"
10
11SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
12 file://rsyncd.conf \
13 file://makefile-no-rebuild.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040014 file://CVE-2016-9840.patch \
15 file://CVE-2016-9841.patch \
16 file://CVE-2016-9842.patch \
17 file://CVE-2016-9843.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018"
19
20SRC_URI[md5sum] = "1581a588fde9d89f6bc6201e8129afaf"
21SRC_URI[sha256sum] = "55cc554efec5fdaad70de921cd5a5eeb6c29a95524c715f3bbf849235b0800c0"
22
23inherit autotools
24
Brad Bishop316dfdd2018-06-25 12:45:53 -040025PACKAGECONFIG ??= "acl attr \
26 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
27"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
Brad Bishop316dfdd2018-06-25 12:45:53 -040029PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
30PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
33# By default, if crosscompiling, rsync disables a number of
34# capabilities, hardlinking symlinks and special files (i.e. devices)
35CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
36
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037EXTRA_OEMAKE = 'STRIP=""'
38
Brad Bishop316dfdd2018-06-25 12:45:53 -040039# rsync 3.0 uses configure.sh instead of configure, and
40# makefile checks the existence of configure.sh
41do_configure_prepend () {
42 rm -f ${S}/configure ${S}/configure.sh
43}
44
45do_configure_append () {
46 cp -f ${S}/configure ${S}/configure.sh
47}
48
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049do_install_append() {
50 install -d ${D}${sysconfdir}
51 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
52}
53
Brad Bishop316dfdd2018-06-25 12:45:53 -040054BBCLASSEXTEND = "native"