blob: a4ac46c68e50674916d6d2cf314a021b868d43bf [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006DEPENDS = "flex-native bison-native flex"
Brad Bishop00111322018-04-01 22:23:53 -04007DEPENDS += "libtirpc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008DEPENDS_append_class-nativesdk = " flex-nativesdk"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009
Brad Bishop00111322018-04-01 22:23:53 -040010ASNEEDED = ""
11
Brad Bishop96ff1982019-08-19 13:50:42 -040012S = "${WORKDIR}/git"
13SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://unfs3_parallel_build.patch \
15 file://alternate_rpc_ports.patch \
16 file://fix_pid_race_parent_writes_child_pid.patch \
17 file://fix_compile_warning.patch \
18 file://rename_fh_cache.patch \
19 file://relative_max_socket_path_len.patch \
20 file://tcp_no_delay.patch \
Brad Bishop00111322018-04-01 22:23:53 -040021 file://0001-daemon.c-Libtirpc-porting-fixes.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022 file://0001-attr-fix-utime-for-symlink.patch \
23 "
Brad Bishop96ff1982019-08-19 13:50:42 -040024SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
25UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)"
26
27PV = "0.9.22+${SRCPV}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028
29BBCLASSEXTEND = "native nativesdk"
30
31inherit autotools
32EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
Brad Bishop00111322018-04-01 22:23:53 -040033CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
34LDFLAGS_append = " -ltirpc"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050035
36# Turn off these header detects else the inode search
37# will walk entire file systems and this is a real problem
38# if you have 2 TB of files to walk in your file system
39CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"