blob: 4e89c604d6f37bfa75f9e9db34780273bc58406e [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
Brad Bishop96ff1982019-08-19 13:50:42 -040010DEPENDS = " \
Brad Bishopc342db32019-05-15 21:57:59 -040011 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
12 "
13
14SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
15 file://fixed-perl-path.patch \
16 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
17 file://run-ptest \
18 file://0004-Fix-out-of-tree-builds.patch \
19 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
20 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
21 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
22 file://avoid-neon-for-targets-which-don-t-support-it.patch \
23 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
24 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
25 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
26 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
27 file://0002-context-APIs-are-not-available-on-musl.patch \
28 file://0003-correct-include-directive-path-for-config.h.patch \
29 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
30 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
31 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
32 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
33 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
34 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
35 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
36 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
37 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
38 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
39 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
40 file://0002-valgrind-adjust-std_list-expected-output.patch \
41 "
42SRC_URI[md5sum] = "46e5fbdcbc3502a5976a317a0860a975"
43SRC_URI[sha256sum] = "417c7a9da8f60dd05698b3a7bc6002e4ef996f14c13f0ff96679a16873e78ab1"
44UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
45
46COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
47
48# valgrind supports armv7 and above
49COMPATIBLE_HOST_armv4 = 'null'
50COMPATIBLE_HOST_armv5 = 'null'
51COMPATIBLE_HOST_armv6 = 'null'
52
53# X32 isn't supported by valgrind at this time
54COMPATIBLE_HOST_linux-gnux32 = 'null'
55COMPATIBLE_HOST_linux-muslx32 = 'null'
56
57# Disable for some MIPS variants
58COMPATIBLE_HOST_mipsarchr6 = 'null'
59COMPATIBLE_HOST_linux-gnun32 = 'null'
60
61# Disable for powerpc64 with musl
62COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
63
64inherit autotools ptest multilib_header
65
66EXTRA_OECONF = "--enable-tls --without-mpicc"
67EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
68
69# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
70EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
71
72EXTRA_OEMAKE = "-w"
73
74CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
75
76# valgrind likes to control its own optimisation flags. It generally defaults
77# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
78# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
79# which fixes build path issue in DWARF.
80SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
81
82do_configure_prepend () {
83 rm -rf ${S}/config.h
84 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
85 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
86}
87
88do_install_append () {
89 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
90 oe_multilib_header valgrind/config.h
91}
92
93VALGRINDARCH ?= "${TARGET_ARCH}"
94VALGRINDARCH_aarch64 = "arm64"
95VALGRINDARCH_x86-64 = "amd64"
96VALGRINDARCH_x86 = "x86"
97VALGRINDARCH_mips = "mips32"
98VALGRINDARCH_mipsel = "mips32"
99VALGRINDARCH_mips64el = "mips64"
100VALGRINDARCH_powerpc = "ppc"
101VALGRINDARCH_powerpc64 = "ppc64"
102VALGRINDARCH_powerpc64el = "ppc64le"
103
104INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
105
106RDEPENDS_${PN} += "perl"
107
108# valgrind needs debug information for ld.so at runtime in order to
109# redirect functions like strlen.
110RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
111
Brad Bishop15ae2502019-06-18 21:44:24 -0400112RDEPENDS_${PN}-ptest += " file perl perl-module-file-glob sed ${PN}-dbg"
Brad Bishopc342db32019-05-15 21:57:59 -0400113RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
114
115# One of the tests contains a bogus interpreter path on purpose.
116# Skip file dependency check
117SKIP_FILEDEPS_${PN}-ptest = '1'
118INSANE_SKIP_${PN}-ptest = "debug-deps"
119
120do_compile_ptest() {
121 oe_runmake check
122}
123
124do_install_ptest() {
125 chmod +x ${B}/tests/vg_regtest
126
127 # The test application binaries are not automatically installed.
128 # Grab them from the build directory.
129 #
130 # The regression tests require scripts and data files that are not
131 # copied to the build directory. They must be copied from the
132 # source directory.
133 saved_dir=$PWD
134 for parent_dir in ${S} ${B} ; do
135 cd $parent_dir
136
137 # exclude shell or the package won't install
138 rm -rf none/tests/shell* 2>/dev/null
139
140 subdirs=" \
141 cachegrind/tests \
142 callgrind/tests \
143 drd/tests \
144 gdbserver_tests \
145 helgrind/tests \
146 massif/tests \
147 memcheck/tests \
148 none/tests \
149 tests \
150 "
151
152 # Get the vg test scripts, filters, and expected files
153 for dir in $subdirs ; do
154 find $dir | cpio -pvdu ${D}${PTEST_PATH}
155 done
156 cd $saved_dir
157 done
158
159 # Hide then restore a.c that is used by ann[12].vgtest in call/cachegrind
160 mv ${D}${PTEST_PATH}/cachegrind/tests/a.c ${D}${PTEST_PATH}/cachegrind/tests/a_c
161 # clean out build artifacts before building the rpm
162 find ${D}${PTEST_PATH} \
163 \( -name "Makefile*" \
164 -o -name "*.o" \
165 -o -name "*.c" \
166 -o -name "*.S" \
167 -o -name "*.h" \) \
168 -exec rm {} \;
169 mv ${D}${PTEST_PATH}/cachegrind/tests/a_c ${D}${PTEST_PATH}/cachegrind/tests/a.c
Brad Bishop15ae2502019-06-18 21:44:24 -0400170 touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test
Brad Bishopc342db32019-05-15 21:57:59 -0400171
172 # find *_annotate in ${bindir} for yocto build
173 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
174 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
175
176 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
177 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
178
179 # needed by massif tests
180 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
181
182 # handle multilib
183 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
184}