blob: a821fd8bf336c4819cb38652bcc64609521b20e5 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Linux Standard Base (LSB)"
6DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specification"
7PR = "r10"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
9inherit packagegroup distro_features_check
10
11# The libxt, libxtst and others require x11 in DISTRO_FEATURES
12REQUIRED_DISTRO_FEATURES = "x11"
13
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014# libglu needs virtual/libgl, which requires opengl in DISTRO_FEATURES
15REQUIRED_DISTRO_FEATURES += "opengl"
16
Brad Bishop316dfdd2018-06-25 12:45:53 -040017# libpam, pam-plugin-wheel requires pam in DISTRO_FEATURES
18REQUIRED_DISTRO_FEATURES += "pam"
19
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020#
21# We will skip parsing this packagegeoup for non-glibc systems
22#
23python __anonymous () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024 if d.getVar('TCLIBC') != "glibc":
Brad Bishop316dfdd2018-06-25 12:45:53 -040025 raise bb.parse.SkipRecipe("incompatible with %s C library" %
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 d.getVar('TCLIBC'))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027}
28
29PACKAGES = "\
30 packagegroup-core-lsb \
31 packagegroup-core-sys-extended \
32 packagegroup-core-db \
33 packagegroup-core-perl \
34 packagegroup-core-python \
35 packagegroup-core-tcl \
36 packagegroup-core-lsb-misc \
37 packagegroup-core-lsb-core \
38 packagegroup-core-lsb-perl \
39 packagegroup-core-lsb-python \
40 packagegroup-core-lsb-desktop \
41 packagegroup-core-lsb-runtime-add \
42 "
43
44
45RDEPENDS_packagegroup-core-lsb = "\
46 packagegroup-core-sys-extended \
47 packagegroup-core-db \
48 packagegroup-core-perl \
49 packagegroup-core-python \
50 packagegroup-core-tcl \
51 packagegroup-core-lsb-misc \
52 packagegroup-core-lsb-core \
53 packagegroup-core-lsb-perl \
54 packagegroup-core-lsb-python \
55 packagegroup-core-lsb-desktop \
56 packagegroup-core-lsb-runtime-add \
57 "
58
59
60RDEPENDS_packagegroup-core-sys-extended = "\
61 curl \
62 dhcp-client \
63 hdparm \
64 lighttpd \
65 libaio \
66 lrzsz \
67 lzo \
68 mc \
69 mc-fish \
70 mc-helpers \
71 mc-helpers-perl \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050072 mdadm \
73 minicom \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 parted \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 quota \
76 screen \
77 setserial \
78 sysstat \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080079 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'udev-extraconf', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 unzip \
81 watchdog \
82 wget \
83 which \
84 xinetd \
85 zip \
86 "
87
88RDEPENDS_packagegroup-core-db = "\
89 db \
90 sqlite3 \
91 "
92
93RDEPENDS_packagegroup-core-perl = "\
94 gdbm \
95 perl \
96 zlib \
97 "
98
99
100RDEPENDS_packagegroup-core-python = "\
101 expat \
102 gdbm \
103 gmp \
104 ncurses \
105 openssl \
106 python \
107 readline \
108 zip \
109 "
110
111RDEPENDS_packagegroup-core-tcl = "\
112 tcl \
113 "
114
115# Miscellaneous packages required by LSB (or LSB tests)
116RDEPENDS_packagegroup-core-lsb-misc = "\
117 chkconfig \
118 gettext \
119 gettext-runtime \
120 groff \
121 lsbinitscripts \
122 lsbtest \
123 lsof \
124 strace \
125 libusb1 \
126 usbutils \
127 rpm \
128 "
129
130SUMMARY_packagegroup-core-lsb-core = "LSB Core"
131DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
132 specified in the LSB Core specification"
133RDEPENDS_packagegroup-core-lsb-core = "\
134 at \
135 bash \
136 bc \
137 binutils \
138 binutils-symlinks \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800139 bzip2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 coreutils \
141 cpio \
142 cronie \
143 cups \
144 diffutils \
145 ed \
146 glibc-utils \
147 elfutils \
148 file \
149 findutils \
150 fontconfig-utils \
151 foomatic-filters \
152 gawk \
153 ghostscript \
154 grep \
155 gzip \
156 localedef \
157 lsb \
158 m4 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159 make \
160 man \
161 man-pages \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500162 msmtp \
163 patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500164 procps \
165 psmisc \
166 sed \
167 shadow \
168 tar \
169 time \
170 util-linux \
171 xdg-utils \
172 \
173 glibc \
174 libgcc \
175 libpam \
176 libxml2 \
177 ncurses \
178 zlib \
179 nspr \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500180 nss \
181"
182
183SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
184DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
185 specified in the LSB Runtime languages specification (Perl parts)"
186RDEPENDS_packagegroup-core-lsb-perl = "\
187 perl \
188 perl-modules \
189 perl-misc \
190 perl-pod \
191 perl-dev \
192 perl-doc \
193"
194
195SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
196DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
197 specified in the LSB Runtime languages specification (Python parts)"
198RDEPENDS_packagegroup-core-lsb-python = "\
199 python \
200 python-modules \
201 python-misc \
202"
203
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500204SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
205DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
206 specified in the LSB Desktop specification"
207RDEPENDS_packagegroup-core-lsb-desktop = "\
208 libxt \
209 libxxf86vm \
210 libdrm \
211 libglu \
212 libxi \
213 libxtst \
214 libx11-locale \
215 xorg-minimal-fonts \
216 gdk-pixbuf-loader-ico \
217 gdk-pixbuf-loader-bmp \
218 gdk-pixbuf-loader-ani \
219 gdk-pixbuf-xlib \
220 liberation-fonts \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800221 alsa-lib \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500222"
223
224RDEPENDS_packagegroup-core-lsb-runtime-add = "\
225 ldd \
226 pam-plugin-wheel \
227 e2fsprogs-mke2fs \
228 mkfontdir \
229 liburi-perl \
230 libxml-parser-perl \
231 libxml-perl \
232 libxml-sax-perl \
233 glibc-localedatas \
234 glibc-gconvs \
235 glibc-charmaps \
236 glibc-binaries \
237 glibc-localedata-posix \
238 glibc-extra-nss \
239 glibc-pcprofile \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500240"