blob: 635dee1942a7717cd6ed3caa97ae8b197b85d859 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Meta-python ptest packagegroups"
Brad Bishop19323692019-04-05 15:28:33 -04002
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
Brad Bishop19323692019-04-05 15:28:33 -04007 packagegroup-meta-python3 \
8'
9
Andrew Geisslereef63862021-01-29 15:58:13 -060010# Note that python3-cvxopt requires Fortran support. To enable this,
11# add the following to your local.conf:
12# FORTRAN_forcevariable = ",fortran"
Brad Bishop19323692019-04-05 15:28:33 -040013RDEPENDS_packagegroup-meta-python3 = "\
Andrew Geisslereef63862021-01-29 15:58:13 -060014 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
15 ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
16 gyp \
Andrew Geisslerd688a012020-09-18 13:36:00 -050017 pamela \
18 pyrtm \
Andrew Geisslereef63862021-01-29 15:58:13 -060019 python3-absl \
Andrew Geisslerd688a012020-09-18 13:36:00 -050020 python3-aenum \
Andrew Geisslerd688a012020-09-18 13:36:00 -050021 python3-aiofiles \
Andrew Geisslerd688a012020-09-18 13:36:00 -050022 python3-aiohttp \
Andrew Geisslereef63862021-01-29 15:58:13 -060023 python3-aiohttp-jinja2 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050024 python3-alembic \
25 python3-ansi2html \
26 python3-ansicolors \
Andrew Geisslereef63862021-01-29 15:58:13 -060027 python3-anyjson \
Andrew Geisslerd688a012020-09-18 13:36:00 -050028 python3-appdirs \
29 python3-apply-defaults \
Andrew Geisslereef63862021-01-29 15:58:13 -060030 python3-argcomplete \
31 python3-argexec \
Andrew Geisslerd688a012020-09-18 13:36:00 -050032 python3-argh \
Andrew Geisslerd688a012020-09-18 13:36:00 -050033 python3-arpeggio \
Andrew Geisslereef63862021-01-29 15:58:13 -060034 python3-asciitree \
Andrew Geisslerd688a012020-09-18 13:36:00 -050035 python3-asn1crypto \
Andrew Geisslereef63862021-01-29 15:58:13 -060036 python3-astor \
37 python3-astroid \
38 python3-asttokens \
Andrew Geisslerd688a012020-09-18 13:36:00 -050039 python3-async-timeout \
Andrew Geisslerd688a012020-09-18 13:36:00 -050040 python3-attr \
Andrew Geisslerd688a012020-09-18 13:36:00 -050041 python3-autobahn \
Andrew Geisslerd688a012020-09-18 13:36:00 -050042 python3-automat \
Andrew Geisslerd688a012020-09-18 13:36:00 -050043 python3-aws-iot-device-sdk-python \
Andrew Geisslereef63862021-01-29 15:58:13 -060044 python3-babel \
Andrew Geisslerd688a012020-09-18 13:36:00 -050045 python3-backcall \
46 python3-backports-functools-lru-cache \
Andrew Geisslereef63862021-01-29 15:58:13 -060047 python3-bandit \
48 python3-bcrypt \
Andrew Geisslerd688a012020-09-18 13:36:00 -050049 python3-beautifulsoup4 \
Andrew Geisslerd688a012020-09-18 13:36:00 -050050 python3-behave \
Andrew Geisslereef63862021-01-29 15:58:13 -060051 python3-betamax \
Andrew Geisslerd688a012020-09-18 13:36:00 -050052 python3-bitarray \
53 python3-bitstring \
54 python3-bitstruct \
Andrew Geisslereef63862021-01-29 15:58:13 -060055 python3-blinker \
56 python3-blivet \
Andrew Geisslerd688a012020-09-18 13:36:00 -050057 python3-booleanpy \
Andrew Geisslereef63862021-01-29 15:58:13 -060058 python3-cachecontrol \
Andrew Geisslerd688a012020-09-18 13:36:00 -050059 python3-cachetools \
60 python3-can \
61 python3-cantools \
62 python3-cassandra-driver \
63 python3-cbor2 \
Andrew Geisslereef63862021-01-29 15:58:13 -060064 python3-cerberus \
Andrew Geisslerd688a012020-09-18 13:36:00 -050065 python3-certifi \
Andrew Geisslereef63862021-01-29 15:58:13 -060066 python3-cffi \
67 python3-chardet \
Andrew Geisslerd688a012020-09-18 13:36:00 -050068 python3-cheetah \
69 python3-click \
Andrew Geisslereef63862021-01-29 15:58:13 -060070 python3-click-repl \
71 python3-click-spinner \
72 python3-cmd2 \
73 python3-colorama \
Andrew Geisslerd688a012020-09-18 13:36:00 -050074 python3-coloredlogs \
75 python3-colorlog \
Andrew Geisslereef63862021-01-29 15:58:13 -060076 python3-configargparse \
77 python3-configobj \
78 python3-configparser \
Andrew Geisslerd688a012020-09-18 13:36:00 -050079 python3-configshell-fb \
80 python3-constantly \
81 python3-contextlib2 \
Andrew Geisslereef63862021-01-29 15:58:13 -060082 python3-coverage \
Andrew Geisslerd688a012020-09-18 13:36:00 -050083 python3-cppy \
Andrew Geisslereef63862021-01-29 15:58:13 -060084 python3-crcmod \
85 python3-croniter \
86 python3-cryptography \
87 python3-cryptography-vectors \
88 python3-cson \
89 python3-custom-inherit \
90 python3-cvxopt \
91 python3-cycler \
92 python3-dateparser \
Andrew Geisslerd688a012020-09-18 13:36:00 -050093 python3-dateutil \
Andrew Geisslereef63862021-01-29 15:58:13 -060094 python3-dbus-next \
95 python3-dbussy \
96 python3-decorator \
97 python3-defusedxml \
98 python3-dill \
99 python3-diskcache \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500100 python3-distro \
Andrew Geisslereef63862021-01-29 15:58:13 -0600101 python3-django \
102 python3-django-south \
103 python3-djangorestframework \
104 python3-dnspython \
105 python3-docopt \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500106 python3-dominate \
Andrew Geisslereef63862021-01-29 15:58:13 -0600107 python3-dt-schema \
108 python3-dynamic-dispatch \
109 python3-ecdsa \
110 python3-editor \
111 python3-engineio \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500112 python3-et-xmlfile \
Andrew Geisslereef63862021-01-29 15:58:13 -0600113 python3-evdev \
114 python3-fann2 \
115 python3-fasteners \
116 python3-fastnumbers \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500117 python3-feedformatter \
Andrew Geisslereef63862021-01-29 15:58:13 -0600118 python3-flask \
119 python3-flask-babel \
120 python3-flask-bootstrap \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500121 python3-flask-jsonpify \
122 python3-flask-jwt \
Andrew Geisslereef63862021-01-29 15:58:13 -0600123 python3-flask-login \
124 python3-flask-mail \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500125 python3-flask-migrate \
Andrew Geisslereef63862021-01-29 15:58:13 -0600126 python3-flask-nav \
127 python3-flask-pymongo \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500128 python3-flask-restful \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500129 python3-flask-script \
130 python3-flask-sijax \
Andrew Geisslereef63862021-01-29 15:58:13 -0600131 python3-flask-socketio \
132 python3-flask-sqlalchemy \
133 python3-flask-uploads \
134 python3-flask-user \
135 python3-flask-versioned \
136 python3-flask-wtf \
137 python3-flask-xstatic \
138 python3-future \
139 python3-gast \
140 python3-geojson \
141 python3-gevent \
142 python3-gmpy2 \
143 python3-gmqtt \
144 python3-gnupg \
145 python3-google-api-python-client \
146 python3-graphviz \
147 python3-greenlet \
148 python3-greenstalk \
149 python3-grpcio \
150 python3-grpcio-tools \
151 python3-gsocketpool \
152 python3-gunicorn \
153 python3-h2 \
154 python3-h5py \
155 python3-haversine \
156 python3-hexdump \
157 python3-hpack \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500158 python3-html2text \
159 python3-html5lib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600160 python3-httplib2 \
161 python3-huey \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500162 python3-humanfriendly \
Andrew Geisslereef63862021-01-29 15:58:13 -0600163 python3-humanize \
164 python3-hyperframe \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500165 python3-hyperlink \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500166 python3-icu \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500167 python3-idna \
Andrew Geisslereef63862021-01-29 15:58:13 -0600168 python3-idna \
169 python3-idna-ssl \
170 python3-imageio \
171 python3-incremental \
172 python3-inflection \
Andrew Geissler97771a32021-03-05 15:23:11 -0600173 python3-intelhex \
Andrew Geisslereef63862021-01-29 15:58:13 -0600174 python3-intervals \
175 python3-ipaddress \
176 python3-ipy \
177 python3-ipython \
178 python3-ipython-genutils \
179 python3-iso3166 \
180 python3-iso8601 \
181 python3-isodate \
182 python3-isort \
183 python3-itsdangerous \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500184 python3-javaobj-py3 \
Andrew Geisslereef63862021-01-29 15:58:13 -0600185 python3-jdatetime \
186 python3-jdcal \
187 python3-jedi \
188 python3-jsmin \
189 python3-jsonpatch \
190 python3-jsonpath-rw \
191 python3-jsonpointer \
192 python3-jsonref \
193 python3-jsonrpcserver \
194 python3-jsonschema \
195 python3-jstyleson \
196 python3-kconfiglib \
197 python3-keras-applications \
198 python3-keras-preprocessing \
199 python3-kiwisolver \
200 python3-langtable \
201 python3-lazy-object-proxy \
202 python3-libconf \
203 python3-license-expression \
204 python3-lockfile \
205 python3-lorem \
206 python3-lrparsing \
207 python3-luma-core \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500208 python3-luma-oled \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500209 python3-lxml \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500210 python3-lz4 \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500211 python3-m2crypto \
Andrew Geisslereef63862021-01-29 15:58:13 -0600212 python3-markdown \
213 python3-markupsafe \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500214 python3-matplotlib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600215 python3-mccabe \
216 python3-meh \
217 python3-meld3 \
218 python3-mock \
219 python3-monotonic \
220 python3-mpmath \
221 python3-msgpack \
222 python3-msk \
223 python3-msm \
224 python3-multidict \
225 python3-mypy \
226 python3-mypy-extensions \
227 python3-natsort \
228 python3-ndg-httpsclient \
229 python3-netaddr \
230 python3-netifaces \
231 python3-networkx \
232 python3-nmap \
233 python3-nocasedict \
234 python3-nocaselist \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500235 python3-ntplib \
Andrew Geisslereef63862021-01-29 15:58:13 -0600236 python3-oauthlib \
237 python3-obd \
238 python3-openpyxl \
239 python3-ordered-set \
240 python3-padaos \
241 python3-padatious \
242 python3-paho-mqtt \
243 python3-pako \
244 python3-pandas \
245 python3-parallax \
246 python3-paramiko \
247 python3-parse \
248 python3-parse-type \
249 python3-parso \
250 python3-passlib \
251 python3-pathtools3 \
252 python3-pep8 \
253 python3-periphery \
254 python3-petact \
255 python3-pexpect \
256 python3-pickleshare \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500257 python3-pid \
Andrew Geisslereef63862021-01-29 15:58:13 -0600258 python3-pika \
259 python3-pillow \
260 python3-pint \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500261 python3-pkgconfig \
Andrew Geisslereef63862021-01-29 15:58:13 -0600262 python3-ply \
263 python3-pocketsphinx \
264 python3-polyline \
265 python3-prctl \
266 python3-precise-runner \
267 python3-pretend \
268 python3-prettytable \
269 python3-priority \
270 python3-progress \
271 python3-prompt-toolkit \
272 python3-protobuf \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500273 python3-psutil \
Andrew Geisslereef63862021-01-29 15:58:13 -0600274 python3-ptyprocess \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500275 python3-pulsectl \
276 python3-py-ubjson \
277 python3-pyalsaaudio \
Andrew Geisslereef63862021-01-29 15:58:13 -0600278 python3-pyasn1 \
279 python3-pyasn1-modules \
280 python3-pyatspi \
281 python3-pyaudio \
282 python3-pybind11 \
283 python3-pybind11-json \
284 python3-pybluez \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500285 python3-pychromecast \
Andrew Geisslereef63862021-01-29 15:58:13 -0600286 python3-pycodestyle \
287 python3-pyconnman \
288 python3-pycparser \
289 python3-pycrypto \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500290 python3-pycurl \
Andrew Geisslereef63862021-01-29 15:58:13 -0600291 python3-pydbus \
Andrew Geissler97771a32021-03-05 15:23:11 -0600292 python3-pydbus-manager \
Andrew Geisslereef63862021-01-29 15:58:13 -0600293 python3-pydicti \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500294 python3-pyephem \
Andrew Geisslereef63862021-01-29 15:58:13 -0600295 python3-pyexpect \
296 python3-pyfirmata \
297 python3-pyflakes \
298 python3-pyhamcrest \
299 python3-pyiface \
300 python3-pyinotify \
301 python3-pyjks \
302 python3-pyjwt \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500303 python3-pykickstart \
Andrew Geisslereef63862021-01-29 15:58:13 -0600304 python3-pykwalify \
305 python3-pylint \
306 python3-pylyrics \
307 python3-pymisp \
308 python3-pymongo \
309 python3-pymysql \
310 python3-pynacl \
311 python3-pynetlinux \
312 python3-pyopenssl \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500313 python3-pyparted \
Andrew Geisslereef63862021-01-29 15:58:13 -0600314 python3-pyperclip \
315 python3-pyperf \
316 python3-pyrad \
317 python3-pyro4 \
318 python3-pyroute2 \
319 python3-pyrsistent \
320 python3-pyscaffold \
321 python3-pyserial \
322 python3-pysocks \
323 python3-pystache \
324 python3-pystemd \
325 python3-pytest-asyncio \
326 python3-pytest-helpers-namespace \
327 python3-pytest-html \
328 python3-pytest-metadata \
329 python3-pytest-runner \
330 python3-pytest-tempdir \
331 python3-pytest-timeout \
332 python3-python-vlc \
333 python3-pytoml \
334 python3-pytun \
335 python3-pytz \
336 python3-pyudev \
337 python3-pyusb \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500338 python3-pywbem \
339 python3-pywbemtools \
Andrew Geisslereef63862021-01-29 15:58:13 -0600340 python3-pyyaml \
341 python3-pyzmq \
342 python3-qrcode \
343 python3-raven \
344 python3-rdflib \
345 python3-redis \
346 python3-regex \
347 python3-requests \
348 python3-requests-file \
349 python3-requests-ftp \
350 python3-requests-futures \
351 python3-requests-oauthlib \
352 python3-requests-toolbelt \
353 python3-rfc3339-validator \
354 python3-rfc3986-validator \
355 python3-rfc3987 \
356 python3-robotframework \
357 python3-robotframework-seriallibrary \
358 python3-rsa \
359 python3-ruamel-yaml \
360 python3-scapy \
361 python3-scrypt \
362 python3-sdnotify \
363 python3-semver \
364 python3-send2trash \
365 python3-sentry-sdk \
366 python3-serpent \
367 python3-sh \
368 python3-sijax \
369 python3-simpleeval \
370 python3-simplejson \
371 python3-slip-dbus \
372 python3-smbus \
373 python3-smbus2 \
374 python3-smpplib \
375 python3-snappy \
376 python3-socketio \
377 python3-soupsieve \
378 python3-speaklater \
379 python3-speedtest-cli \
380 python3-spidev \
381 python3-spidev \
382 python3-sqlalchemy \
383 python3-sqlparse \
384 python3-sqlsoup \
385 python3-stevedore \
386 python3-strict-rfc3339 \
387 python3-supervisor \
388 python3-sympy \
389 python3-tabulate \
390 python3-term \
391 python3-termcolor \
392 python3-test-generator \
393 python3-textparser \
394 python3-texttable \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500395 python3-thrift \
Andrew Geisslereef63862021-01-29 15:58:13 -0600396 python3-tinyrecord \
397 python3-tornado \
398 python3-tqdm \
399 python3-trafaret \
400 python3-trafaret-config \
401 python3-traitlets \
402 python3-transitions \
403 python3-twine \
404 python3-twisted \
405 python3-twitter \
406 python3-twofish \
407 python3-txaio \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500408 python3-txws \
Andrew Geisslereef63862021-01-29 15:58:13 -0600409 python3-typed-ast \
410 python3-typeguard \
411 python3-typing-extensions \
412 python3-tzlocal \
413 python3-u-msgpack-python \
414 python3-ujson \
415 python3-unidiff \
416 python3-uritemplate \
417 python3-urllib3 \
418 python3-vcversioner \
419 python3-versiontools \
420 python3-visitor \
421 python3-waitress \
422 python3-watchdog \
423 python3-webcolors \
424 python3-webencodings \
425 python3-websocket-client \
426 python3-websockets \
427 python3-werkzeug \
428 python3-werkzeug \
429 python3-wheel \
430 python3-whoosh \
431 python3-wrapt \
432 python3-wtforms \
433 python3-xlrd \
434 python3-xlsxwriter \
435 python3-xmlrunner \
436 python3-xmltodict \
437 python3-xmodem \
438 python3-xstatic \
439 python3-xstatic-font-awesome \
440 python3-xxhash \
441 python3-yamlloader \
442 python3-yappi \
443 python3-yarl \
444 python3-zopeinterface \
Andrew Geisslerd688a012020-09-18 13:36:00 -0500445 telepathy-python3 \
Brad Bishop19323692019-04-05 15:28:33 -0400446"
447
Brad Bishop19323692019-04-05 15:28:33 -0400448RDEPENDS_packagegroup-meta-python3-ptest = "\
Andrew Geisslerd688a012020-09-18 13:36:00 -0500449 python3-cryptography-ptest \
Andrew Geisslera2681d92020-10-16 10:17:07 -0500450 python3-jinja2-ptest \
451 python3-markupsafe-ptest \
Andrew Geisslereef63862021-01-29 15:58:13 -0600452 python3-ansicolors-ptest \
453 python3-anyjson-ptest \
454 python3-appdirs-ptest \
455 python3-backports-functools-lru-cache-ptest \
456 python3-bcrypt-ptest \
457 python3-betamax-ptest \
458 python3-blinker-ptest \
459 python3-cachetools-ptest \
460 python3-cbor2-ptest \
461 python3-click-ptest \
462 python3-cryptography-ptest \
463 python3-dnspython-ptest \
464 python3-dominate-ptest \
465 python3-geojson-ptest \
466 python3-gunicorn-ptest \
467 python3-html2text-ptest \
468 python3-inflection-ptest \
469 python3-intervals-ptest \
470 python3-ipy-ptest \
471 python3-iso3166-ptest \
472 python3-jdcal-ptest \
473 python3-jinja2-ptest \
474 python3-jsmin-ptest \
475 python3-jsonpointer-ptest \
476 python3-license-expression-ptest \
477 python3-markupsafe-ptest \
478 python3-msgpack-ptest \
479 python3-multidict-ptest \
480 python3-ordered-set-ptest \
481 python3-parse-ptest \
482 python3-parse-type-ptest \
483 python3-pint-ptest \
484 python3-polyline-ptest \
485 python3-precise-runner-ptest \
486 python3-prettytable-ptest \
487 python3-ptyprocess-ptest \
488 python3-pyasn1-modules-ptest \
489 python3-pyroute2-ptest \
490 python3-pyserial-ptest \
491 python3-pytoml-ptest \
492 python3-pytz-ptest \
493 python3-requests-file-ptest \
494 python3-requests-toolbelt-ptest \
495 python3-scrypt-ptest \
496 python3-semver-ptest \
497 python3-serpent-ptest \
498 python3-simpleeval-ptest \
499 python3-smpplib-ptest \
500 python3-soupsieve-ptest \
501 python3-sqlparse-ptest \
502 python3-test-generator-ptest \
503 python3-typeguard-ptest \
504 python3-ujson-ptest \
505 python3-u-msgpack-python-ptest \
506 python3-unidiff-ptest \
507 python3-uritemplate-ptest \
508 python3-webcolors-ptest \
509 python3-whoosh-ptest \
510 python3-xlrd-ptest \
511 python3-xmltodict-ptest \
512 python3-xxhash-ptest \
513 python3-yappi-ptest \
514 python3-yarl-ptest \
515 python3-pyasn1-ptest \
Andrew Geisslera2681d92020-10-16 10:17:07 -0500516"
Brad Bishop19323692019-04-05 15:28:33 -0400517
518EXCLUDE_FROM_WORLD = "1"