blob: f54d966c731fbae9680ac9a0ed3f3ddc8a89ba40 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007DEPENDS = " \
8 libxml2-native \
9 sassc-native \
10 gtk4 \
11 mutter \
12 evolution-data-server \
13 gcr \
14 gjs \
15 gnome-autoar \
16 polkit \
17 libcroco \
18 startup-notification \
19 ibus \
20 gsettings-desktop-schemas \
21"
22
Patrick Williams58776372022-04-13 09:07:35 -050023inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
24
25REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
26
27GTKIC_VERSION = "4"
Andrew Geissler595f6302022-01-24 19:11:47 +000028GTKDOC_MESON_OPTION = "gtk_doc"
29GIR_MESON_OPTION = ""
30
31# gobject-introspection is mandatory and cannot be configured
32REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
33
Patrick Williams58776372022-04-13 09:07:35 -050034SRC_URI[archive.sha256sum] = "33d404fb3c93b9de42984f0110a2969d6a4a7247c27fe7f5e24c67ecfec75094"
Andrew Geissler595f6302022-01-24 19:11:47 +000035SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
Andrew Geissler595f6302022-01-24 19:11:47 +000036
37PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
38PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
39PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
40PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
41
42EXTRA_OEMESON = " \
43 -Dgjs_path=${bindir}/gjs \
44 -Dextensions-app:gjs_path=${bindir}/gjs \
45 -Dtests=false \
46 -Dman=false \
47"
48
49do_install:append() {
50 # fix shebangs
51 for tool in `find ${D}${bindir} -name '*-tool'`; do
52 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
53 done
54}
55
56GSETTINGS_PACKAGE = "${PN}-gsettings"
57
58FILES:${PN} += " \
59 ${datadir}/metainfo \
60 ${datadir}/dbus-1 \
61 ${datadir}/gnome-control-center \
62 ${datadir}/xdg-desktop-portal \
63 ${systemd_user_unitdir} \
64"
65
66RDEPENDS:${PN} += "gnome-desktop gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings"
67
68PACKAGES =+ "${PN}-tools ${PN}-gsettings"
69FILES:${PN}-tools = "${bindir}/*-tool"
70RDEPENDS:${PN}-tools = "python3-core"
71