Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SECTION = "console/utils" |
| 2 | SUMMARY = "A free SOCKS server" |
| 3 | DESCRIPTION = "Dante consists of a SOCKS server and a SOCKS client,\ |
| 4 | implementing RFC 1928 and related standards. It is a flexible product\ |
| 5 | that can be used to provide convenient and secure network\ |
| 6 | connectivity. Once installed, Dante can in most cases be made\ |
| 7 | transparent to clients, providing functionality somewhat similar to\ |
| 8 | what could be described as a non-transparent Layer 4 router." |
| 9 | HOMEPAGE = "http://www.inet.no/dante/" |
| 10 | |
| 11 | LICENSE = "BSD-3-Clause" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=edd508404db7339042dfc861a3a690ad" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "https://www.inet.no/dante/files/dante-${PV}.tar.gz \ |
| 15 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "418a065fe1a4b8ace8fbf77c2da269a98f376e7115902e76cda7e741e4846a5d" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | |
| 18 | # without --without-gssapi, config.log will contain reference to /usr/lib |
| 19 | # as a consequence of GSSAPI path being set to /usr by default. |
| 20 | # --with-gssapi-path=PATH specify gssapi path |
| 21 | # --without-gssapi disable gssapi support |
| 22 | # --enable-release build prerelease as full release |
| 23 | EXTRA_OECONF += "--without-gssapi --sbindir=${bindir}" |
| 24 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 25 | DEPENDS += "flex-native bison-native libpam libtirpc" |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 26 | inherit autotools-brokensep features_check |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 28 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
| 29 | LIBS += "-ltirpc" |
| 30 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | REQUIRED_DISTRO_FEATURES = "pam" |
| 32 | |
| 33 | EXTRA_AUTORECONF = "-I ${S}" |
| 34 | |
| 35 | PACKAGECONFIG[libwrap] = ",--disable-libwrap,tcp-wrappers,libwrap" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 36 | |
| 37 | PACKAGECONFIG ??= "" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | do_install:append() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 40 | install -d ${D}${sysconfdir} |
| 41 | cp ${S}/example/sock[sd].conf ${D}${sysconfdir} |
| 42 | } |
| 43 | |
| 44 | PACKAGES =+ "${PN}-sockd ${PN}-libdsocks " |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN}-libdsocks = "${libdir}/libdsocks.so" |
| 47 | FILES:${PN}-sockd = "${bindir}/sockd ${sysconfdir}/sockd.conf" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 48 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | INSANE_SKIP:${PN}-libdsocks = "dev-elf" |