blob: 691bbce9aca0a37a640e99e4b5aac1e51a412747 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION="Protocol Buffers with small code size"
2LICENSE="Zlib"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9db4b73a55a3994384112efcdb37c01f"
4
5DEPENDS = "protobuf-native"
6
Andrew Geissler595f6302022-01-24 19:11:47 +00007SRC_URI = "git://github.com/nanopb/nanopb.git;branch=master;protocol=https"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008SRCREV = "afc499f9a410fc9bbf6c9c48cdd8d8b199d49eb4"
Brad Bishope42b3e32020-01-15 22:08:42 -05009
10S = "${WORKDIR}/git"
11
Andrew Geissler82c905d2020-04-13 13:39:40 -050012inherit cmake python3native
Brad Bishope42b3e32020-01-15 22:08:42 -050013
Patrick Williams213cb262021-08-07 19:21:33 -050014do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050015 install -Dm 0755 ${S}/generator/nanopb_generator.py ${D}${bindir}/nanopb_generator.py
16 install -Dm 0755 ${S}/generator/protoc-gen-nanopb ${D}${bindir}/protoc-gen-nanopb
17 install -Dm 0755 ${S}/generator/proto/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/proto/__init__.py
18}
19
Patrick Williams213cb262021-08-07 19:21:33 -050020FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
21FILES:${PN}-dev += "${libdir}/cmake/${BPN}"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023RDEPENDS:${PN} += "\
Brad Bishope42b3e32020-01-15 22:08:42 -050024 ${PYTHON_PN}-protobuf \
25 protobuf-compiler \
26"
27
28BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050029