blob: c52ff30fdacdb6f1a487ac4e0bb1de61377abb19 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Simplified object serialization in python"
2DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
3AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
4HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "\
7 file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
8 file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
9
10SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRCREV = "2805f32461fc7801a5f7b6d83facf7cbb8bca278"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
Andrew Geissler9aee5002022-03-30 16:27:02 +000018PIP_INSTALL_PACKAGE = "marshmallow"
19
Patrick Williams03907ee2022-05-01 06:28:52 -050020RDEPENDS:${PN} += " \
21 python3-core \
22 python3-datetime \
23 python3-netclient \
24 python3-numbers \
25 python3-json \
26 python3-pprint \
27 python3-packaging \
28"