blob: b4068b0598be83af5767c03e519ad18510dd433e [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
Patrick Williams2390b1b2022-11-03 13:47:49 -05008SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
9SRCREV = "03493cb69e91c29718ff9f645514355cd99762c6"
Patrick Williams92b42cb2022-09-03 06:53:57 -050010S = "${WORKDIR}/git"
11
12DEPENDS = "coreutils-native"
13
14PROVIDES = "stress"
15RPROVIDES:${PN} = "stress"
16RREPLACES:${PN} = "stress"
17RCONFLICTS:${PN} = "stress"
18
19inherit bash-completion
20
Patrick Williams7784c422022-11-17 07:29:11 -060021EXTRA_OEMAKE = "VERBOSE=1"
22
23do_configure() {
Patrick Williams92b42cb2022-09-03 06:53:57 -050024 mkdir -p configs
25 touch configs/HAVE_APPARMOR
Patrick Williams7784c422022-11-17 07:29:11 -060026 oe_runmake makeconfig
Patrick Williams92b42cb2022-09-03 06:53:57 -050027}
28
29do_install() {
Patrick Williams7784c422022-11-17 07:29:11 -060030 oe_runmake DESTDIR=${D} BINDIR=${bindir} install
Patrick Williams92b42cb2022-09-03 06:53:57 -050031 ln -s stress-ng ${D}${bindir}/stress
32}