Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "low-level tool handling Linux filesystem encryption" |
| 2 | DESCIPTION = "fscryptctl is a low-level tool written in C that handles raw keys and manages \ |
| 3 | policies for Linux filesystem encryption (https://lwn.net/Articles/639427). \ |
| 4 | For a tool that presents a higher level interface and manages metadata, key \ |
| 5 | generation, key wrapping, PAM integration, and passphrase hashing, see \ |
| 6 | fscrypt (https://github.com/google/fscrypt)." |
| 7 | HOMEPAGE = "https://github.com/google/fscryptctl" |
| 8 | SECTION = "base" |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
Andrew Geissler | dc9d614 | 2023-05-19 09:38:37 -0500 | [diff] [blame] | 12 | SRCREV = "7c80c73c084ce9ea49a03b814dac7a82fd7b4c23" |
Patrick Williams | 53961c2 | 2022-01-20 11:06:23 -0600 | [diff] [blame] | 13 | SRC_URI = "git://github.com/google/fscryptctl.git;branch=master;protocol=https" |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Andrew Geissler | dc9d614 | 2023-05-19 09:38:37 -0500 | [diff] [blame] | 17 | do_compile:prepend() { |
| 18 | sed -i 's/fscryptctl\.1//g' ${S}/Makefile |
| 19 | sed -i 's/install-man//g' ${S}/Makefile |
| 20 | } |
| 21 | |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 22 | do_install() { |
Andrew Geissler | 9d3cc05 | 2021-03-31 13:36:22 -0500 | [diff] [blame] | 23 | oe_runmake DESTDIR=${D} PREFIX=/usr install |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 24 | } |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | RRECOMMENDS:${PN} += "\ |
Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 27 | keyutils \ |
| 28 | kernel-module-cbc \ |
| 29 | kernel-module-cts \ |
| 30 | kernel-module-ecb \ |
| 31 | kernel-module-xts \ |
| 32 | " |