blob: 4fcac31a468c21126d40ad34b7ffcc14a8422b21 [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Kuiying Wang91ff72a2018-11-08 16:52:49 +08005DEPENDS += " \
6 systemd \
7 sdbusplus \
8 phosphor-dbus-interfaces \
9 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080010 "
Ed Tanous9936f862022-09-19 09:13:20 -070011SRCREV = "a6d4e65d5c4c78f86d690fff31b79db9fa8c3b4c"
12PACKAGECONFIG ??= "signals handler"
13PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
14PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
15PV = "1.0+git${SRCPV}"
16PR = "r1"
17
18SRC_URI += "git://github.com/openbmc/phosphor-buttons.git;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
22SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
23SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
24
25inherit meson pkgconfig systemd
26
27FILES:${PN}-signals = "${bindir}/buttons"
28FILES:${PN}-handler = "${bindir}/button-handler"
29
30ALLOW_EMPTY:${PN} = "1"
31
32BUTTON_PACKAGES = "${PN}-signals ${PN}-handler"
33
34PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"