blob: a18a7a713a5565c4e9b89e5bf27db44d15e07cef [file] [log] [blame]
Marri Devender Rao7b823182017-06-08 03:17:36 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-host from a MRW."
Ed Tanous9936f862022-09-19 09:13:20 -07002DEPENDS += "mrw-native mrw-perl-tools-native"
3DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
4PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
Patrick Venture8f93a292018-10-26 09:58:28 -07005PV = "1.0+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -07006PR = "r1"
7
8S = "${WORKDIR}/git"
Marri Devender Rao7b823182017-06-08 03:17:36 -05009
Marri Devender Rao7b823182017-06-08 03:17:36 -050010inherit phosphor-ipmi-host
Matt Spinler0a8ea632017-12-14 13:31:55 -060011inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060012inherit native
Marri Devender Rao7b823182017-06-08 03:17:36 -050013
Marri Devender Rao7b823182017-06-08 03:17:36 -050014do_install() {
Marri Devender Rao7b823182017-06-08 03:17:36 -050015 DEST=${D}${config_datadir}
16 install -d ${DEST}
Marri Devender Rao7b823182017-06-08 03:17:36 -050017 ${bindir}/perl-native/perl \
18 ${bindir}/gen_ipmi_fru.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060019 -i ${mrw_datadir}/${MRW_XML} \
Marri Devender Rao7b823182017-06-08 03:17:36 -050020 -m ${hostfw_datadir}/config.yaml \
21 -o ${DEST}/config.yaml
22}
Ed Tanous9936f862022-09-19 09:13:20 -070023
24require phosphor-ipmi-host.inc