blob: 95bc0633e158e6a0890294f6e5b14e7188479fb5 [file] [log] [blame]
Matt Spinler1b8b9042016-08-25 13:04:09 -05001SUMMARY = "Phosphor machine readable workbook patching script"
2DESCRIPTION = "Retrieve the script that can patch the MRW XML"
Brad Bishopedb390a2018-11-06 10:09:31 -08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Ed Tanous9936f862022-09-19 09:13:20 -07005DEPENDS += "python3-native python3-lxml-native"
6SRCREV = "${MRW_TOOLS_SRCREV}"
7PV = "1.0+git${SRCPV}"
8PR = "r1"
9
10SRC_URI += "${MRW_TOOLS_SRC_URI}"
Matt Spinler1b8b9042016-08-25 13:04:09 -050011
12S = "${WORKDIR}/git"
13
Matt Spinlerb103a332016-09-15 10:39:43 -050014inherit mrw-rev
Joseph Reynolds79809ea2021-02-26 15:37:31 -060015inherit native
Matt Spinler1b8b9042016-08-25 13:04:09 -050016
Matt Spinler1b8b9042016-08-25 13:04:09 -050017do_install() {
Matt Spinler98c33e32016-09-20 13:32:44 -050018 install -d ${D}${bindir}/obmc-mrw
19 install -m 0755 patchxml.py ${D}${bindir}/obmc-mrw
Matt Spinler1b8b9042016-08-25 13:04:09 -050020}