blob: bf67245bca3628888be85f7f8a32f6a94ff2a0e2 [file] [log] [blame]
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05001SUMMARY = "PLDM Stack"
2DESCRIPTION = "Implementation of the PLDM specifications"
Tom Josephf6785aa2021-06-15 07:12:34 -07003DEPENDS += "function2"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05004DEPENDS += "systemd"
Matt Spinlere2375b52020-01-20 14:09:47 -06005DEPENDS += "sdeventplus"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05006DEPENDS += "phosphor-dbus-interfaces"
7DEPENDS += "nlohmann-json"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -05008DEPENDS += "cli11"
Ed Tanous9936f862022-09-19 09:13:20 -07009PV = "1.0+git${SRCPV}"
10PR = "r1"
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050011
12S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050013SYSTEMD_SERVICE:${PN} += "pldmd.service"
14SYSTEMD_SERVICE:${PN} += "pldmSoftPowerOff.service"
Deepak Kodihallia7482012020-06-22 05:25:35 -050015
Ed Tanous9936f862022-09-19 09:13:20 -070016inherit meson pkgconfig
17inherit systemd
18
Deepak Kodihalli7a113ee2019-10-14 01:23:27 -050019EXTRA_OEMESON = " \
20 -Dtests=disabled \
21 -Doem-ibm=disabled \
22 "
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050023
Ed Tanous9936f862022-09-19 09:13:20 -070024pkg_prerm:${PN} () {
25 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
26 rm $LINK
27 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
28 rm $LINK
29}
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050030# Install pldmSoftPowerOff.service in correct targets
Patrick Williams12fc9392021-08-06 09:16:53 -050031pkg_postinst:${PN} () {
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053032 mkdir -p $D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants
33 LINK="$D$systemd_system_unitdir/obmc-host-shutdown@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050034 TARGET="../pldmSoftPowerOff.service"
35 ln -s $TARGET $LINK
Manojkiran Eda842eb7f2021-09-15 18:47:42 +053036 mkdir -p $D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants
37 LINK="$D$systemd_system_unitdir/obmc-host-warm-reboot@0.target.wants/pldmSoftPowerOff.service"
Andrew Geissler0c3d0e22020-10-28 16:43:35 -050038 TARGET="../pldmSoftPowerOff.service"
39 ln -s $TARGET $LINK
40}
41
Ed Tanous9936f862022-09-19 09:13:20 -070042require pldm.inc