blob: 93b6f560036770ae61c96f369aa0c446e0a53391 [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
Andrew Geisslerae4211c2018-12-10 19:00:27 +000010SRCREV = "391a21a1bb002a62ce336bfacdd8fdf888b7909a"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080011
12inherit cmake pkgconfig systemd
13
Matt Spinler9ad66412018-11-26 15:37:30 -060014BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
15
16ALLOW_EMPTY_${PN} = "1"
17PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
18PACKAGECONFIG ??= "signals handler"
19SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
20
21PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
22PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
23
24FILES_${PN}-signals = "${sbindir}/buttons"
25SYSTEMD_SERVICE_${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
26
27FILES_${PN}-handler = "${sbindir}/button-handler"
28SYSTEMD_SERVICE_${PN}-handler = "phosphor-button-handler.service"
Kuiying Wang91ff72a2018-11-08 16:52:49 +080029
30DEPENDS += " \
31 systemd \
32 sdbusplus \
33 phosphor-dbus-interfaces \
34 phosphor-logging \
Kuiying Wang91ff72a2018-11-08 16:52:49 +080035 "