blob: acde9c3659c47781a9b60c66a4c7adeacc268d1b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Open-LLDP"
2DESCRIPTION = "Link Layer Discovery Protocol for Linux that includes support for DCBX"
3HOMEPAGE = "http://open-lldp.org/start"
4
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162"
7
8S = "${WORKDIR}/git"
9
10inherit pkgconfig autotools
11inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}
12
13DEPENDS = "libnl libconfig readline"
14
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050015SRCREV = "b71bfb87fefb31c4b1a6a7ae351791c90966c3a8"
16PV .= "+git${SRCPV}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017SRC_URI = "git://github.com/intel/openlldp.git;protocol=https;branch=master \
18 file://0001-Fix-musl-libc-build-issue.patch \
19 file://0001-autotools-Add-include-path-to-generated-version.h.patch \
20 file://0001-autotools-Add-option-to-disable-installation-of-syst.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021 file://0001-cmds-fix-enum-conversion.patch \
22 file://0002-lldp_head-rename-and-make-extern.patch \
23 file://0003-lldp-add-packed-struct-definition.patch \
24 file://0004-lldptool-make-extern.patch \
25 file://0005-cisco_oui-match-encode-handler-prototypes.patch \
26 file://0006-ecp22-make-enum-a-type-rather-than-instance.patch \
27 file://0007-lldp_8021qaz-extern-config-object.patch \
28 file://0008-stringops-fix-some-string-copy-errors.patch \
29 file://0009-8021qaz-mark-prio-map-functions-static.patch \
Patrick Williams213cb262021-08-07 19:21:33 -050030 file://lldp_head-remove-all-references.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050031 "
32
33# Makefile.am adds -Werror to AM_CFLAGS. There are warnings so disable it.
34TARGET_CFLAGS += "-Wno-error"
35
36# Enable install of systemd conf files.
37EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_system_unitdir}', '', d)}"
38
Patrick Williams213cb262021-08-07 19:21:33 -050039SYSTEMD_SERVICE:${PN} = "lldpad.service lldpad.socket"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040
41# To enable service at boot set to enable in local.conf.
42SYSTEMD_AUTO_ENABLE ?= "disable"
43
Patrick Williams213cb262021-08-07 19:21:33 -050044RRECOMMENDS:${PN} = "iproute2-tc"