blob: 9cac20499859511bc4aaebf86b38bc972de4974a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
Brad Bishopc342db32019-05-15 21:57:59 -040016UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/traceroute/"
17
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019"
Patrick Williamsddad1a12017-02-23 20:36:32 -060020SRC_URI[md5sum] = "84d329d67abc3fb83fc8cb12aeaddaba"
21SRC_URI[sha256sum] = "3669d22a34d3f38ed50caba18cd525ba55c5c00d5465f2d20d7472e5d81603b6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050022
23EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060024LTOEXTRA += "-flto-partition=none"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025
26do_compile() {
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027 oe_runmake "env=yes"
28}
29
30do_install() {
31 install -d ${D}${bindir}
32 install -m755 ${BPN}/${BPN} ${D}${bindir}
33
34 install -m755 wrappers/tcptraceroute ${D}${bindir}
35
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036 install -d ${D}${mandir}/man8
37 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}/man8
38 ln -s ${BPN}.8 ${D}${mandir}/man8/${BPN}6.8
39 ln -s ${BPN}.8 ${D}${mandir}/man8/tcptraceroute.8
Patrick Williamsb48b7b42016-08-17 15:04:38 -050040
41}
42
Andrew Geissler72956ed2021-01-08 16:11:14 -060043ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050044ALTERNATIVE:${PN} = "traceroute"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"