blob: d7e422cc97bcf2261ebac27bcb4d9d7da186e778 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
Andrew Geissler9aee5002022-03-30 16:27:02 +00006LICENSE = "LGPL-2.1-only"
Brad Bishop90ca7472019-08-20 09:15:15 -04007LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Brad Bishop8410d612019-11-25 09:40:59 -05009inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
Brad Bishop26bdd442019-08-16 17:08:17 -040010
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015# PV is 3.28 not 3.28.0, so the gnomebase SRC_URI isn't right.
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz;name=archive"
Brad Bishop90ca7472019-08-20 09:15:15 -040017SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
18SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
Brad Bishop26bdd442019-08-16 17:08:17 -040019
20EXTRA_OECONF = "--disable-gtk3-engine"
21
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:append() {
Brad Bishop26bdd442019-08-16 17:08:17 -040023 # Only building Adwaita, remove highcontrast files
24 rm -rf ${D}${prefix}/share/themes/HighContrast \
25 ${D}${prefix}/share/icons
26
27 # The libtool archive file is unneeded with shared libs on modern Linux
28 rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
29}
30
31# There could be gnome-theme-highcontrast as well but that requires
32# gtk+3 and includes lots of icons (is also broken with B != S).
33PACKAGES += "gnome-theme-adwaita \
34 gnome-theme-adwaita-dark \
35 "
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
Brad Bishop26bdd442019-08-16 17:08:17 -040038 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
39
Patrick Williams213cb262021-08-07 19:21:33 -050040FILES:gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
41RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita"
Brad Bishop26bdd442019-08-16 17:08:17 -040042
43# gnome-themes-standard is empty and doesn't exist
Patrick Williams213cb262021-08-07 19:21:33 -050044RDEPENDS:${PN}-dev = ""