blob: bdc37c03829d8225af4bfc735ec0b1c4c711d218 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License version 2 as
6# published by the Free Software Foundation.
7#
8SUMMARY = "Frequency and Idle power monitoring tools for Linux"
9
10DESCRIPTION = "The turbostat tool allows you to determine the actual \
11processor frequency and idle power saving state residency on supported \
12processors."
13
Andrew Geissler9aee5002022-03-30 16:27:02 +000014LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
16COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
Patrick Williams213cb262021-08-07 19:21:33 -050017COMPATIBLE_HOST:libc-musl = "null"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19SRC_URI += "\
20 file://COPYING \
21 "
22
Brad Bishop26bdd442019-08-16 17:08:17 -040023PACKAGE_ARCH = "${MACHINE_ARCH}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024DEPENDS = "libcap"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
26# This looks in S, so we better make sure there's
27# something in the directory.
28#
29do_populate_lic[depends] = "${PN}:do_configure"
30
31
32EXTRA_OEMAKE = '\
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 CC="${CC}" 'CFLAGS=-Wall ${LDFLAGS}' \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 '
35
36# If we build under STAGING_KERNEL_DIR, source will not be put
37# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
38# do_configure() is invoked so we can safely copy from it.
39#
Andrew Geissler82c905d2020-04-13 13:39:40 -050040do_configure[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williams213cb262021-08-07 19:21:33 -050041do_configure:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042 mkdir -p ${S}
43 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
44 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
Andrew Geissler2ee498a2020-05-29 15:52:06 -050045 if [ -f "${STAGING_KERNEL_DIR}/include/vdso/bits.h" ]; then
46 cp -r ${STAGING_KERNEL_DIR}/include/vdso/bits.h ${S}
47 cp -r ${STAGING_KERNEL_DIR}/include/vdso/const.h ${S}
48 else
49 cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
50 cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
51 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
53 cp -r ${WORKDIR}/COPYING ${S}
54}
55
Andrew Geissler2ee498a2020-05-29 15:52:06 -050056
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057do_compile() {
Brad Bishop15ae2502019-06-18 21:44:24 -040058 sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h
Andrew Geissler2ee498a2020-05-29 15:52:06 -050059 'TMPCHECK='grep "<vdso/const.h>" bits.h'' || true
60 if [ -n $TMPCHECK ]; then
61 sed -i 's#<vdso/const.h>#"const.h"#' bits.h
62 sed -i 's#<uapi/linux/const.h>#<linux/const.h>#' const.h
63 else
64 sed -i 's#<linux/const.h>#"const.h"#' bits.h
65 sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
66 fi
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080067 sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
68 sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
69 sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile
70 oe_runmake STAGING_KERNEL_DIR=${STAGING_KERNEL_DIR}
71}
72
73do_install() {
74 oe_runmake DESTDIR="${D}" install
75}