blob: cbb51d3477cd056cbefa53480bafac09193d1719 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Console mouse driver"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
3for the console and xterm, with sample clients included \
4(emacs, etc)."
Brad Bishopc342db32019-05-15 21:57:59 -04005HOMEPAGE = "https://www.nico.schottelius.org/software/gpm"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SECTION = "console/utils"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
9
10PV = "1.99.7+git${SRCREV}"
11PR = "r2"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050012SRCREV = "e82d1a653ca94aa4ed12441424da6ce780b1e530"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS = "ncurses bison-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/telmich/gpm;protocol=https;branch=master \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://init \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 file://gpm.service.in \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020
21S = "${WORKDIR}/git"
22
Andrew Geissler82c905d2020-04-13 13:39:40 -050023inherit autotools-brokensep update-rc.d systemd texinfo
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
25INITSCRIPT_NAME = "gpm"
26INITSCRIPT_PARAMS = "defaults"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028do_configure:prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029 (cd ${S};./autogen.sh;cd -)
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032do_install:append () {
Brad Bishopc342db32019-05-15 21:57:59 -040033 install -d ${D}${systemd_system_unitdir}
34 sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
35 install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036 ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
37}
38
Patrick Williams213cb262021-08-07 19:21:33 -050039SYSTEMD_SERVICE:${PN} = "gpm.service"