blob: fa263775b3990ab8ec28795d76dc031b90adc70f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://libtool-tag.patch \
Andrew Geisslerb7d28612020-07-24 16:15:54 -050011 file://run-ptest \
12 file://0001-Add-output-of-tests-result.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 "
14
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015SRC_URI[sha256sum] = "b2c160f1b60e92da69de8e12333096aeb0c3bf692d41c60794de278af72135a5"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
Andrew Geisslerb7d28612020-07-24 16:15:54 -050017EXTRA_OECMAKE_class-native += "-DEXPAT_BUILD_DOCS=OFF"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
Andrew Geisslerb7d28612020-07-24 16:15:54 -050019RDEPENDS_${PN}-ptest += "bash"
20
21inherit cmake lib_package ptest
22
23do_install_ptest_class-target() {
24 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025}
26
Andrew Geisslerb7d28612020-07-24 16:15:54 -050027BBCLASSEXTEND += "native nativesdk"