Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=41a76b4b1f816240f090cf010fefebf0" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "acaff68b14f1e0804ebbfc4b97268a4ccbefcfa053b02ed9924f2b14d8a98e21" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 21 | |
| 22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 23 | |
| 24 | S = "${WORKDIR}/acpica-unix-${PV}" |
| 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_PRIORITY = "100" |
| 29 | ALTERNATIVE:${PN} = "acpixtract acpidump" |
| 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 32 | OPT_CFLAGS=-Wall \ |
| 33 | DESTDIR=${D} \ |
| 34 | PREFIX=${prefix} \ |
| 35 | INSTALLDIR=${bindir} \ |
| 36 | INSTALLFLAGS= \ |
| 37 | YACC=bison \ |
| 38 | YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \ |
| 39 | " |
| 40 | |
| 41 | do_install() { |
| 42 | oe_runmake install |
| 43 | } |
| 44 | |
| 45 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 46 | PROVIDES = "iasl" |
| 47 | RPROVIDES:${PN} += "iasl" |
| 48 | RREPLACES:${PN} += "iasl" |
| 49 | RCONFLICTS:${PN} += "iasl" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |