blob: 2f46fa952367e8a9e50c185d6a5a54b01c064dd5 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "kexecboot linux-as-bootloader"
2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
3HOMEPAGE = "http://kexecboot.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.6+git${SRCPV}"
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/kexecboot/kexecboot.git"
Brad Bishop19323692019-04-05 15:28:33 -04009SRC_URI_append_libc-klibc = " file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch "
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012inherit autotools
13
14EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
15
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050016CFLAGS += "-fcommon"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018do_install () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019 install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020 install -d ${D}/proc
21 install -d ${D}/mnt
22 install -d ${D}/dev
23 install -d ${D}/sys
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
29
30pkg_postinst_${PN} () {
31 ln -sf ${bindir}/kexecboot $D/init
32}
33
34BBCLASSEXTEND = "klibc"