blob: 3e57682cd2510ff037d6061d285a3beae0b68b00 [file] [log] [blame]
Patrick Venture6dd5cc92018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturea9f19bd2019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venturea26ccf52019-05-03 10:35:28 -070017DEPENDS += "pciutils"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080018
19S = "${WORKDIR}/git"
20SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Patrick Venturea26ccf52019-05-03 10:35:28 -070021SRCREV = "241416115e13659b9cb6cef9e77e469c1f99f640"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080022
23FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
25FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
26
27BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"