blob: ea1fa4c754b5e988aecc4121d834ec071cbea31a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Device formfactor information"
Brad Bishopa34c0302019-09-23 22:34:48 -04002DESCRIPTION = "A formfactor configuration file provides information about the \
3target hardware for which the image is being built and information that the \
4build system cannot obtain from other sources such as the kernel."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005SECTION = "base"
6LICENSE = "MIT"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008PR = "r45"
9
10SRC_URI = "file://config file://machconfig"
11S = "${WORKDIR}"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14INHIBIT_DEFAULT_DEPS = "1"
15
16do_install() {
17 # Install file only if it has contents
18 install -d ${D}${sysconfdir}/formfactor/
19 install -m 0644 ${S}/config ${D}${sysconfdir}/formfactor/
20 if [ -s "${S}/machconfig" ]; then
21 install -m 0644 ${S}/machconfig ${D}${sysconfdir}/formfactor/
22 fi
23}