blob: a2983c5770cdbfb87a8c94adc594fa8664f1605a [file] [log] [blame]
Brad Bishopa34c0302019-09-23 22:34:48 -04001From 77cb4a53c270d5854d3af24f19547bc3de825233 Mon Sep 17 00:00:00 2001
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002From: James Cowgill <james410@cowgill.org.uk>
3Date: Mon, 5 Jan 2015 15:16:58 +0000
Brad Bishopa34c0302019-09-23 22:34:48 -04004Subject: [PATCH 1/3] Ignore differences between mips machine identifiers
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005
6Little endian binaries actually use EM_MIPS so you can't tell the endianness
7from the elf machine id. Also, the EM_MIPS_RS3_LE machine is dead anyway (the
8kernel will not load binaries containing it).
9
10Signed-off-by: James Cowgill <james410@cowgill.org.uk>
Brad Bishopa34c0302019-09-23 22:34:48 -040011
Brad Bishopa5c52ff2018-11-23 10:55:50 +130012Upstream-Status: Pending [from debian]
13Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014---
15 backends/mips_init.c | 6 +-----
16 1 file changed, 1 insertion(+), 5 deletions(-)
17
Brad Bishopa34c0302019-09-23 22:34:48 -040018Index: b/backends/mips_init.c
19===================================================================
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020--- a/backends/mips_init.c
21+++ b/backends/mips_init.c
Brad Bishopa34c0302019-09-23 22:34:48 -040022@@ -45,11 +45,7 @@ mips_init (Elf *elf __attribute__ ((unus
Brad Bishop6e60e8b2018-02-01 10:27:11 -050023 return NULL;
24
25 /* We handle it. */
26- if (machine == EM_MIPS)
27- eh->name = "MIPS R3000 big-endian";
28- else if (machine == EM_MIPS_RS3_LE)
29- eh->name = "MIPS R3000 little-endian";
30-
31+ eh->name = "MIPS";
32 mips_init_reloc (eh);
33 HOOK (eh, reloc_simple_type);
34 HOOK (eh, return_value_location);