blob: e85a2fed9d27db5fb22cc72b73d0cbad504f6d7d [file] [log] [blame]
Brad Bishopa5c52ff2018-11-23 10:55:50 +13001Upstream-Status: Pending [from debian]
2Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Brad Bishop19323692019-04-05 15:28:33 -04003
Brad Bishopa34c0302019-09-23 22:34:48 -04004Index: b/tests/run-native-test.sh
5===================================================================
Brad Bishopa5c52ff2018-11-23 10:55:50 +13006--- a/tests/run-native-test.sh
7+++ b/tests/run-native-test.sh
8@@ -77,6 +77,12 @@ native_test()
9 test $native -eq 0 || testrun "$@" -p $native > /dev/null
10 }
11
12+# On the Debian buildds, GNU/kFreeBSD linprocfs /proc/$PID/maps does
13+# not give absolute paths due to sbuild's bind mounts (bug #570805)
14+# therefore the next two test programs are expected to fail with
15+# "cannot attach to process: Function not implemented".
16+[ "$(uname)" = "GNU/kFreeBSD" ] && exit 77
17+
18 native_test ${abs_builddir}/allregs
19 native_test ${abs_builddir}/funcretval
20