blob: c6d42e163a158b5f2d288b0f1ebe53f284797367 [file] [log] [blame]
Brad Bishopa34c0302019-09-23 22:34:48 -04001From 7bdc83296865cf2b2a5615dbdb7ac0d441fb1849 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Wed, 21 Aug 2019 16:55:01 +0800
4Subject: [PATCH] mips_readelf_w
Brad Bishopa5c52ff2018-11-23 10:55:50 +13005
6Upstream-Status: Pending [from debian]
Brad Bishopa5c52ff2018-11-23 10:55:50 +13007
Brad Bishopa34c0302019-09-23 22:34:48 -04008Rebase to 0.177
9
10Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Brad Bishop19323692019-04-05 15:28:33 -040011---
12 src/readelf.c | 3 ++-
13 1 file changed, 2 insertions(+), 1 deletion(-)
14
15diff --git a/src/readelf.c b/src/readelf.c
Brad Bishopa34c0302019-09-23 22:34:48 -040016index 2084fb1..5c02a9b 100644
Brad Bishop19323692019-04-05 15:28:33 -040017--- a/src/readelf.c
18+++ b/src/readelf.c
Brad Bishopa34c0302019-09-23 22:34:48 -040019@@ -11256,7 +11256,8 @@ print_debug (Dwfl_Module *dwflmod, Ebl *ebl, GElf_Ehdr *ehdr)
Brad Bishopa5c52ff2018-11-23 10:55:50 +130020 GElf_Shdr shdr_mem;
21 GElf_Shdr *shdr = gelf_getshdr (scn, &shdr_mem);
22
23- if (shdr != NULL && shdr->sh_type == SHT_PROGBITS)
24+ if (shdr != NULL && (
25+ (shdr->sh_type == SHT_PROGBITS) || (shdr->sh_type == SHT_MIPS_DWARF)))
26 {
27 static const struct
28 {
Brad Bishopa34c0302019-09-23 22:34:48 -040029--
302.7.4
31