blob: d005dc4a9032c9aa78939e042697adad96c3f8da [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
Brad Bishop96ff1982019-08-19 13:50:42 -04006DEPENDS = "expat dbus glib-2.0 virtual/libintl"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007
Brad Bishopa34c0302019-09-23 22:34:48 -04008SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
Brad Bishopa34c0302019-09-23 22:34:48 -040010SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4"
11SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260"
12
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
18# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
19EXTRA_OECONF += "--disable-documentation"
20
21
22RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
23
24FILES_${PN}-dev += "${libdir}/pkgconfig"
Brad Bishop08902b02019-08-20 09:16:51 -040025
26BBCLASSEXTEND = "native nativesdk"