blob: 13fe304a57e514795af26b67dc50bfbc43bec613 [file] [log] [blame]
Andrew Geissler26e4bea2020-11-30 19:54:03 -06001SUMMARY = "cmdline.txt file used to boot the kernel on a Raspberry Pi device"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5COMPATIBLE_MACHINE = "^rpi$"
6INHIBIT_DEFAULT_DEPS = "1"
7inherit deploy nopackages
8
9CMDLINE_DWC_OTG ?= "dwc_otg.lpm_enable=0"
10CMDLINE_ROOTFS ?= "root=/dev/mmcblk0p2 rootfstype=ext4 rootwait"
11
12CMDLINE_SERIAL ?= "${@oe.utils.conditional("ENABLE_UART", "1", "console=serial0,115200", "", d)}"
13
14CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_CAMERA_V2", "1", "cma=64M", "", d)}"
15
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070016CMDLINE_CMA ?= "${@oe.utils.conditional("RASPBERRYPI_HD_CAMERA", "1", "cma=64M", "", d)}"
17
Andrew Geissler26e4bea2020-11-30 19:54:03 -060018CMDLINE_PITFT ?= "${@bb.utils.contains("MACHINE_FEATURES", "pitft", "fbcon=map:10 fbcon=font:VGA8x8", "", d)}"
19
20# Add the kernel debugger over console kernel command line option if enabled
21CMDLINE_KGDB ?= '${@oe.utils.conditional("ENABLE_KGDB", "1", "kgdboc=serial0,115200", "", d)}'
22
23# Disable rpi logo on boot
24CMDLINE_LOGO ?= '${@oe.utils.conditional("DISABLE_RPI_BOOT_LOGO", "1", "logo.nologo", "", d)}'
25
26# You can define CMDLINE_DEBUG as "debug" in your local.conf or distro.conf
27# to enable kernel debugging.
28CMDLINE_DEBUG ?= ""
29
30CMDLINE = " \
31 ${CMDLINE_DWC_OTG} \
32 ${CMDLINE_SERIAL} \
33 ${CMDLINE_ROOTFS} \
34 ${CMDLINE_CMA} \
35 ${CMDLINE_KGDB} \
36 ${CMDLINE_LOGO} \
37 ${CMDLINE_PITFT} \
38 ${CMDLINE_DEBUG} \
39 "
40
41do_compile() {
Andrew Geissler11105212021-02-12 15:30:38 -060042 echo "${@' '.join('${CMDLINE}'.split())}" > "${WORKDIR}/cmdline.txt"
Andrew Geissler26e4bea2020-11-30 19:54:03 -060043}
44
45do_deploy() {
46 install -d "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
47 install -m 0644 "${WORKDIR}/cmdline.txt" "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
48}
49
50addtask deploy before do_build after do_install
51do_deploy[dirs] += "${DEPLOYDIR}/${BOOTFILES_DIR_NAME}"
Andrew Geisslera4353c82021-06-25 14:23:27 -050052
53PACKAGE_ARCH = "${MACHINE_ARCH}"