blob: e5dba70df07dfc1c93a0a00e900fba545b149ccf [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-only | MIT"
Andrew Geissler615f2f12022-07-15 14:00:58 -050010LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
Andrew Geissler5082cc72023-09-11 08:41:39 -040013 file://0001-Fixes-build-failure-on-.-configure-make-shuffle-2836.patch"
Andrew Geissler595f6302022-01-24 19:11:47 +000014SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
Andrew Geissler5082cc72023-09-11 08:41:39 -040016SRCREV = "298c083d75ecde5a8833366167b3b6abff0c8d39"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
18S = "${WORKDIR}/git"
19
20DEPENDS:append:libc-musl = " libucontext"
21XCFLAGS = "-pthread"
22XCFLAGS:append:libc-musl = " -lucontext"
23
24EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
25do_configure() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000026 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000027}
28do_install () {
Andrew Geissler9aee5002022-03-30 16:27:02 +000029 oe_runmake install DESTDIR=${D}
Andrew Geissler595f6302022-01-24 19:11:47 +000030}
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060031
32BBCLASSEXTEND = "native nativesdk"