blob: 758ba012829b87df6779ffdb6462fc23430234aa [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Venture3adb97a2018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture9afb6712018-09-17 17:14:46 -07008
9inherit autotools pkgconfig
Patrick Venture9afb6712018-09-17 17:14:46 -070010inherit systemd
11inherit obmc-phosphor-ipmiprovider-symlink
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "sdbusplus"
15DEPENDS += "phosphor-logging"
Patrick Venture9afb6712018-09-17 17:14:46 -070016DEPENDS += "phosphor-ipmi-host"
17
Patrick Venture9afb6712018-09-17 17:14:46 -070018S = "${WORKDIR}/git"
19SRC_URI = "git://github.com/openbmc/google-ipmi-sys"
Andrew Geisslera5ec2d92018-12-17 23:20:06 +000020SRCREV = "3c7037a728b7e6f6c808b5694bf8ebf14df255a7"
Patrick Venture9afb6712018-09-17 17:14:46 -070021
22FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
23FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
24FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
25FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
26
27HOSTIPMI_PROVIDER_LIBRARY += "libsyscmds.so"
28
29SYSTEMD_PACKAGES = "${PN}"
30SYSTEMD_SERVICE_${PN} = "gbmc-psu-hardreset.target"
31
32do_install_append() {
33 install -d ${D}${systemd_system_unitdir}
34 install -m 0644 ${S}/gbmc-psu-hardreset.target ${D}${systemd_system_unitdir}
35}