blob: 92dacb95416d21532b76598f426055d61f929dea [file] [log] [blame]
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -06001SUMMARY = "Network DBUS object"
2DESCRIPTION = "Network DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
4PR = "r1"
5
Matthew Barth385b5372016-09-28 13:14:43 -05006inherit autotools pkgconfig
Ratan Gupta153a6dc2017-04-28 10:12:54 +05307inherit pythonnative
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -06008inherit obmc-phosphor-license
Brad Bishop3e7c23d2016-09-06 20:37:22 -04009inherit obmc-phosphor-dbus-service
Patrick Williamsab8de5b2017-05-29 22:08:38 -050010inherit phosphor-networkd-rev
vishwa63f0fce2016-06-20 06:41:52 -050011
Brad Bishop3e7c23d2016-09-06 20:37:22 -040012DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
13SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060014
Matthew Barth0c9d4d22016-10-24 12:51:20 -050015DEPENDS += "systemd"
Matthew Barth385b5372016-09-28 13:14:43 -050016DEPENDS += "autoconf-archive-native"
Ratan Gupta153a6dc2017-04-28 10:12:54 +053017DEPENDS += "sdbusplus sdbusplus-native"
18DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
19DEPENDS += "phosphor-logging"
20
Matthew Barth0c9d4d22016-10-24 12:51:20 -050021RDEPENDS_${PN} += "libsystemd"
Patrick Williams39755642016-08-15 15:59:36 -050022RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy"
Ratan Gupta153a6dc2017-04-28 10:12:54 +053023RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
24RDEPENDS_${PN} += "phosphor-logging"
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060025
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060026S = "${WORKDIR}/git"
27
Brad Bishop3e7c23d2016-09-06 20:37:22 -040028do_install_append() {
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060029 install -d ${D}/${sbindir}
30 install ${S}/netman.py ${D}/${sbindir}
Ratan Gupta9e376b82016-10-24 22:48:11 -050031 install ${S}/conf/network-manager.conf ${D}/${sysconfdir}
Adriana Kobylak30ca4fc2016-01-30 10:41:48 -060032}