Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "A command line tool for updating and displaying info about boot loaders" |
| 2 | DESCRIPTION = "grubby is a command line tool for updating and displaying information \ |
| 3 | about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \ |
| 4 | zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \ |
| 5 | new kernels and need to find information about the current boot environment. \ |
| 6 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | HOMEPAGE = "https://github.com/rhboot/grubby" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-2.0-or-later" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a" |
| 11 | |
| 12 | DEPENDS = "popt util-linux" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | DEPENDS:append:libc-musl = " libexecinfo" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 14 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | SRCREV = "79c5cfa02c567efdc5bb18cdd584789e2e35aa23" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https;;branch=master \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 18 | file://grubby-rename-grub2-editenv-to-grub-editenv.patch \ |
| 19 | file://run-ptest \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \ |
| 21 | file://0002-include-paths.h-for-_PATH_MOUNTED.patch \ |
| 22 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN} += "dracut" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 25 | |
| 26 | inherit autotools-brokensep ptest |
| 27 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 28 | EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | LIBS:libc-musl = "-lexecinfo" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | LIBS ?= "" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH} |
| 34 | cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH} |
| 35 | sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | RDEPENDS:${PN} += "bash" |
| 39 | RDEPENDS:${PN}-ptest = "util-linux-getopt bash" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 40 | |
| 41 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)' |