Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | HOMEPAGE = "https://www.gnu.org/software/help2man/" |
| 3 | DESCRIPTION = "help2man is a tool for automatically generating simple manual pages from program output." |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "GPL-3.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
| 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "9e2e0e213a7e0a36244eed6204d902b6504602a578b6ecd15268b1454deadd36" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 10 | |
| 11 | inherit autotools |
| 12 | |
| 13 | # This is a hand-maintained aclocal.m4 but our autotools class currently deletes |
| 14 | # aclocal.m4. |
| 15 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 16 | |
| 17 | EXTRA_OECONF = "--disable-nls" |
| 18 | |
| 19 | do_install:append () { |
| 20 | # Make sure we use /usr/bin/env perl |
| 21 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 22 | } |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |