blob: 286e0f5d541749ae035d78bef044b6316bd366fb [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# The WICVARS variable is used to define list of bitbake variables used in wic code
2# variables from this list is written to <image>.env file
3WICVARS ?= "\
Andrew Geisslerc9f78652020-09-18 14:11:35 -05004 BBLAYERS IMGDEPLOYDIR DEPLOY_DIR_IMAGE FAKEROOTCMD IMAGE_BASENAME IMAGE_EFI_BOOT_FILES IMAGE_BOOT_FILES \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005 IMAGE_LINK_NAME IMAGE_ROOTFS INITRAMFS_FSTYPES INITRD INITRD_LIVE ISODIR RECIPE_SYSROOT_NATIVE \
Brad Bishop96ff1982019-08-19 13:50:42 -04006 ROOTFS_SIZE STAGING_DATADIR STAGING_DIR STAGING_LIBDIR TARGET_SYS \
Andrew Geisslerc9f78652020-09-18 14:11:35 -05007 KERNEL_IMAGETYPE MACHINE INITRAMFS_IMAGE INITRAMFS_IMAGE_BUNDLE INITRAMFS_LINK_NAME APPEND \
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -05008 ASSUME_PROVIDED PSEUDO_IGNORE_PATHS"
Brad Bishop96ff1982019-08-19 13:50:42 -04009
10inherit ${@bb.utils.contains('INITRAMFS_IMAGE_BUNDLE', '1', 'kernel-artifact-names', '', d)}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
12WKS_FILE ??= "${IMAGE_BASENAME}.${MACHINE}.wks"
13WKS_FILES ?= "${WKS_FILE} ${IMAGE_BASENAME}.wks"
14WKS_SEARCH_PATH ?= "${THISDIR}:${@':'.join('%s/wic' % p for p in '${BBPATH}'.split(':'))}:${@':'.join('%s/scripts/lib/wic/canned-wks' % l for l in '${BBPATH}:${COREBASE}'.split(':'))}"
15WKS_FULL_PATH = "${@wks_search(d.getVar('WKS_FILES').split(), d.getVar('WKS_SEARCH_PATH')) or ''}"
16
17def wks_search(files, search_path):
18 for f in files:
19 if os.path.isabs(f):
20 if os.path.exists(f):
21 return f
22 else:
23 searched = bb.utils.which(search_path, f)
24 if searched:
25 return searched
26
27WIC_CREATE_EXTRA_ARGS ?= ""
28
29IMAGE_CMD_wic () {
30 out="${IMGDEPLOYDIR}/${IMAGE_NAME}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031 build_wic="${WORKDIR}/build-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 wks="${WKS_FULL_PATH}"
33 if [ -z "$wks" ]; then
34 bbfatal "No kickstart files from WKS_FILES were found: ${WKS_FILES}. Please set WKS_FILE or WKS_FILES appropriately."
35 fi
Andrew Geissler82c905d2020-04-13 13:39:40 -050036 BUILDDIR="${TOPDIR}" PSEUDO_UNLOAD=1 wic create "$wks" --vars "${STAGING_DIR}/${MACHINE}/imgdata/" -e "${IMAGE_BASENAME}" -o "$build_wic/" ${WIC_CREATE_EXTRA_ARGS}
37 mv "$build_wic/$(basename "${wks%.wks}")"*.direct "$out${IMAGE_NAME_SUFFIX}.wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050038}
39IMAGE_CMD_wic[vardepsexclude] = "WKS_FULL_PATH WKS_FILES TOPDIR"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040do_image_wic[cleandirs] = "${WORKDIR}/build-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041
Andrew Geissleraf5e4ef2020-10-16 10:22:50 -050042PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/build-wic"
43
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044# Rebuild when the wks file or vars in WICVARS change
45USING_WIC = "${@bb.utils.contains_any('IMAGE_FSTYPES', 'wic ' + ' '.join('wic.%s' % c for c in '${CONVERSIONTYPES}'.split()), '1', '', d)}"
46WKS_FILE_CHECKSUM = "${@'${WKS_FULL_PATH}:%s' % os.path.exists('${WKS_FULL_PATH}') if '${USING_WIC}' else ''}"
47do_image_wic[file-checksums] += "${WKS_FILE_CHECKSUM}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048do_image_wic[depends] += "${@' '.join('%s-native:do_populate_sysroot' % r for r in ('parted', 'gptfdisk', 'dosfstools', 'mtools'))}"
49
50# We ensure all artfacts are deployed (e.g virtual/bootloader)
51do_image_wic[recrdeptask] += "do_deploy"
Andrew Geissler82c905d2020-04-13 13:39:40 -050052do_image_wic[deptask] += "do_image_complete"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050053
Brad Bishop08902b02019-08-20 09:16:51 -040054WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
55WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056WKS_FILE_DEPENDS_BOOTLOADERS = ""
57WKS_FILE_DEPENDS_BOOTLOADERS_x86 = "syslinux grub-efi systemd-boot"
58WKS_FILE_DEPENDS_BOOTLOADERS_x86-64 = "syslinux grub-efi systemd-boot"
59WKS_FILE_DEPENDS_BOOTLOADERS_x86-x32 = "syslinux grub-efi"
60
61WKS_FILE_DEPENDS ??= "${WKS_FILE_DEPENDS_DEFAULT} ${WKS_FILE_DEPENDS_BOOTLOADERS}"
62
Brad Bishop6e60e8b2018-02-01 10:27:11 -050063DEPENDS += "${@ '${WKS_FILE_DEPENDS}' if d.getVar('USING_WIC') else '' }"
64
65python do_write_wks_template () {
66 """Write out expanded template contents to WKS_FULL_PATH."""
67 import re
68
69 template_body = d.getVar('_WKS_TEMPLATE')
70
71 # Remove any remnant variable references left behind by the expansion
72 # due to undefined variables
73 expand_var_regexp = re.compile(r"\${[^{}@\n\t :]+}")
74 while True:
75 new_body = re.sub(expand_var_regexp, '', template_body)
76 if new_body == template_body:
77 break
78 else:
79 template_body = new_body
80
81 wks_file = d.getVar('WKS_FULL_PATH')
82 with open(wks_file, 'w') as f:
83 f.write(template_body)
Brad Bishop08902b02019-08-20 09:16:51 -040084 f.close()
85 # Copy the finalized wks file to the deploy directory for later use
86 depdir = d.getVar('IMGDEPLOYDIR')
87 basename = d.getVar('IMAGE_BASENAME')
88 bb.utils.copyfile(wks_file, "%s/%s" % (depdir, basename + '-' + os.path.basename(wks_file)))
Brad Bishop6e60e8b2018-02-01 10:27:11 -050089}
90
Andrew Geissler82c905d2020-04-13 13:39:40 -050091do_flush_pseudodb() {
92 ${FAKEROOTENV} ${FAKEROOTCMD} -S
93}
94
Brad Bishop6e60e8b2018-02-01 10:27:11 -050095python () {
96 if d.getVar('USING_WIC'):
97 wks_file_u = d.getVar('WKS_FULL_PATH', False)
98 wks_file = d.expand(wks_file_u)
99 base, ext = os.path.splitext(wks_file)
100 if ext == '.in' and os.path.exists(wks_file):
101 wks_out_file = os.path.join(d.getVar('WORKDIR'), os.path.basename(base))
102 d.setVar('WKS_FULL_PATH', wks_out_file)
103 d.setVar('WKS_TEMPLATE_PATH', wks_file_u)
104 d.setVar('WKS_FILE_CHECKSUM', '${WKS_TEMPLATE_PATH}:True')
105
106 # We need to re-parse each time the file changes, and bitbake
107 # needs to be told about that explicitly.
108 bb.parse.mark_dependency(d, wks_file)
109
110 try:
111 with open(wks_file, 'r') as f:
112 body = f.read()
113 except (IOError, OSError) as exc:
114 pass
115 else:
116 # Previously, I used expandWithRefs to get the dependency list
117 # and add it to WICVARS, but there's no point re-parsing the
118 # file in process_wks_template as well, so just put it in
119 # a variable and let the metadata deal with the deps.
120 d.setVar('_WKS_TEMPLATE', body)
Brad Bishop08902b02019-08-20 09:16:51 -0400121 bb.build.addtask('do_write_wks_template', 'do_image_wic', 'do_image', d)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400122 bb.build.addtask('do_image_wic', 'do_image_complete', None, d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500123}
124
125#
126# Write environment variables used by wic
127# to tmp/sysroots/<machine>/imgdata/<image>.env
128#
129python do_rootfs_wicenv () {
130 wicvars = d.getVar('WICVARS')
131 if not wicvars:
132 return
133
134 stdir = d.getVar('STAGING_DIR')
135 outdir = os.path.join(stdir, d.getVar('MACHINE'), 'imgdata')
136 bb.utils.mkdirhier(outdir)
137 basename = d.getVar('IMAGE_BASENAME')
138 with open(os.path.join(outdir, basename) + '.env', 'w') as envf:
139 for var in wicvars.split():
140 value = d.getVar(var)
141 if value:
142 envf.write('%s="%s"\n' % (var, value.strip()))
Brad Bishop08902b02019-08-20 09:16:51 -0400143 envf.close()
144 # Copy .env file to deploy directory for later use with stand alone wic
145 depdir = d.getVar('IMGDEPLOYDIR')
146 bb.utils.copyfile(os.path.join(outdir, basename) + '.env', os.path.join(depdir, basename) + '.env')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500147}
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500148addtask do_flush_pseudodb after do_rootfs before do_image do_image_qa
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500149addtask do_rootfs_wicenv after do_image before do_image_wic
150do_rootfs_wicenv[vardeps] += "${WICVARS}"
151do_rootfs_wicenv[prefuncs] = 'set_image_size'