Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "TOMOYO Linux tools" |
| 2 | DESCRIPTION = "TOMOYO Linux is a Mandatory Access Control (MAC) implementation \ |
| 3 | for Linux that can be used to increase the security of a system, while also \ |
| 4 | being useful purely as a system analysis tool." |
| 5 | HOMEPAGE = "http://tomoyo.sourceforge.jp/" |
| 6 | SECTION = "System Environment/Kernel" |
| 7 | |
| 8 | SRC_URI = "http://jaist.dl.sourceforge.jp/tomoyo/53357/${BP}-20170102.tar.gz" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "00fedfac5e514321250bbe69eaccc732c8a8158596f77a785c2e3ae9f9968283" |
| 10 | |
| 11 | S = "${WORKDIR}/${BPN}" |
| 12 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 13 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://COPYING.tomoyo;md5=751419260aa954499f7abaabaa882bbe" |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | FILES:${PN} += "${libdir}/tomoyo" |
| 17 | FILES:${PN}-dbg += "${libdir}/tomoyo/.debug" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | |
| 19 | DEPENDS = "linux-libc-headers ncurses" |
| 20 | |
| 21 | EXTRA_OEMAKE = "-e USRLIBDIR=${libdir}" |
| 22 | |
| 23 | do_compile () { |
| 24 | oe_runmake 'CC=${CC}' |
| 25 | } |
| 26 | |
| 27 | do_install() { |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 28 | oe_runmake install SBINDIR=${base_sbindir} INSTALLDIR=${D} |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | } |