blob: 0997b3da7a5919f5032541b8845e20fae82d6ee1 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007inherit useradd_base
8
9# base-passwd-cross provides the default passwd and group files in the
10# target sysroot, and shadow -native and -sysroot provide the utilities
11# and support files needed to add and modify user and group accounts
Patrick Williams213cb262021-08-07 19:21:33 -050012DEPENDS:append:class-target = " base-files shadow-native shadow-sysroot shadow base-passwd"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050013PACKAGE_WRITE_DEPS += "shadow-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
15# This preinstall function can be run in four different contexts:
16#
17# a) Before do_install
18# b) At do_populate_sysroot_setscene when installing from sstate packages
19# c) As the preinst script in the target package at do_rootfs time
20# d) As the preinst script in the target package on device as a package upgrade
21#
22useradd_preinst () {
23OPT=""
24SYSROOT=""
25
26if test "x$D" != "x"; then
27 # Installing into a sysroot
28 SYSROOT="$D"
29 OPT="--root $D"
30
31 # Make sure login.defs is there, this is to make debian package backend work
32 # correctly while doing rootfs.
33 # The problem here is that if /etc/login.defs is treated as a config file for
34 # shadow package, then while performing preinsts for packages that depend on
35 # shadow, there might only be /etc/login.def.dpkg-new there in root filesystem.
36 if [ ! -e $D${sysconfdir}/login.defs -a -e $D${sysconfdir}/login.defs.dpkg-new ]; then
37 cp $D${sysconfdir}/login.defs.dpkg-new $D${sysconfdir}/login.defs
38 fi
39
40 # user/group lookups should match useradd/groupadd --root
Brad Bishop6e60e8b2018-02-01 10:27:11 -050041 export PSEUDO_PASSWD="$SYSROOT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042fi
43
44# If we're not doing a special SSTATE/SYSROOT install
45# then set the values, otherwise use the environment
46if test "x$UA_SYSROOT" = "x"; then
47 # Installing onto a target
48 # Add groups and users defined only for this package
49 GROUPADD_PARAM="${GROUPADD_PARAM}"
50 USERADD_PARAM="${USERADD_PARAM}"
51 GROUPMEMS_PARAM="${GROUPMEMS_PARAM}"
52fi
53
54# Perform group additions first, since user additions may depend
55# on these groups existing
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050056if test "x`echo $GROUPADD_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057 echo "Running groupadd commands..."
58 # Invoke multiple instances of groupadd for parameter lists
59 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060060 opts=`echo "$GROUPADD_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
61 remaining=`echo "$GROUPADD_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050062 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050063 perform_groupadd "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064 if test "x$opts" = "x$remaining"; then
65 break
66 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060067 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
68 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050069 done
70fi
71
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050072if test "x`echo $USERADD_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073 echo "Running useradd commands..."
74 # Invoke multiple instances of useradd for parameter lists
75 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060076 opts=`echo "$USERADD_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
77 remaining=`echo "$USERADD_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050078 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050079 perform_useradd "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 if test "x$opts" = "x$remaining"; then
81 break
82 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060083 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
84 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085 done
86fi
87
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050088if test "x`echo $GROUPMEMS_PARAM | tr -d '[:space:]'`" != "x"; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089 echo "Running groupmems commands..."
90 # Invoke multiple instances of groupmems for parameter lists
91 # separated by ';'
Patrick Williamsc0f7c042017-02-23 20:41:17 -060092 opts=`echo "$GROUPMEMS_PARAM" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
93 remaining=`echo "$GROUPMEMS_PARAM" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -050094 while test "x$opts" != "x"; do
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050095 perform_groupmems "$SYSROOT" "$OPT $opts"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050096 if test "x$opts" = "x$remaining"; then
97 break
98 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060099 opts=`echo "$remaining" | cut -d ';' -f 1 | sed -e 's#[ \t]*$##'`
100 remaining=`echo "$remaining" | cut -d ';' -f 2- | sed -e 's#[ \t]*$##'`
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500101 done
102fi
103}
104
105useradd_sysroot () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500106 # Pseudo may (do_prepare_recipe_sysroot) or may not (do_populate_sysroot_setscene) be running
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500107 # at this point so we're explicit about the environment so pseudo can load if
108 # not already present.
Brad Bishop15ae2502019-06-18 21:44:24 -0400109 # PSEUDO_SYSROOT can contain references to the build architecture and COMPONENT_DIR
110 # so needs the STAGING_FIXME below
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500111 export PSEUDO="${FAKEROOTENV} ${PSEUDO_SYSROOT}${bindir_native}/pseudo"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500112
113 # Explicitly set $D since it isn't set to anything
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500114 # before do_prepare_recipe_sysroot
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500115 D=${STAGING_DIR_TARGET}
116
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500117 # base-passwd's postinst may not have run yet in which case we'll get called later, just exit.
118 # Beware that in some cases we might see the fake pseudo passwd here, in which case we also must
119 # exit.
120 if [ ! -f $D${sysconfdir}/passwd ] ||
121 grep -q this-is-the-pseudo-passwd $D${sysconfdir}/passwd; then
122 exit 0
123 fi
124
125 # It is also possible we may be in a recipe which doesn't have useradd dependencies and hence the
126 # useradd/groupadd tools are unavailable. If there is no dependency, we assume we don't want to
127 # create users in the sysroot
128 if ! command -v useradd; then
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500129 bbwarn "command useradd not found!"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500130 exit 0
131 fi
132
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500133 # Add groups and users defined for all recipe packages
134 GROUPADD_PARAM="${@get_all_cmd_params(d, 'groupadd')}"
135 USERADD_PARAM="${@get_all_cmd_params(d, 'useradd')}"
136 GROUPMEMS_PARAM="${@get_all_cmd_params(d, 'groupmems')}"
137
138 # Tell the system to use the environment vars
139 UA_SYSROOT=1
140
141 useradd_preinst
142}
143
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500144# The export of PSEUDO in useradd_sysroot() above contains references to
Brad Bishop15ae2502019-06-18 21:44:24 -0400145# ${PSEUDO_SYSROOT} and ${PSEUDO_LOCALSTATEDIR}. Additionally, the logging
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500146# shell functions use ${LOGFIFO}. These need to be handled when restoring
147# postinst-useradd-${PN} from the sstate cache.
Brad Bishop15ae2502019-06-18 21:44:24 -0400148EXTRA_STAGING_FIXMES += "PSEUDO_SYSROOT PSEUDO_LOCALSTATEDIR LOGFIFO"
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500149
150python useradd_sysroot_sstate () {
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500151 scriptfile = None
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500152 task = d.getVar("BB_CURRENTTASK")
153 if task == "package_setscene":
154 bb.build.exec_func("useradd_sysroot", d)
155 elif task == "prepare_recipe_sysroot":
156 # Used to update this recipe's own sysroot so the user/groups are available to do_install
Patrick Williams169d7bc2024-01-05 11:33:25 -0600157
158 # If do_populate_sysroot is triggered and we write the file here, there would be an overlapping
159 # files. See usergrouptests.UserGroupTests.test_add_task_between_p_sysroot_and_package
160 scriptfile = d.expand("${RECIPE_SYSROOT}${bindir}/postinst-useradd-${PN}-recipedebug")
161
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500162 bb.build.exec_func("useradd_sysroot", d)
163 elif task == "populate_sysroot":
164 # Used when installed in dependent task sysroots
165 scriptfile = d.expand("${SYSROOT_DESTDIR}${bindir}/postinst-useradd-${PN}")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500166
167 if scriptfile:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500168 bb.utils.mkdirhier(os.path.dirname(scriptfile))
169 with open(scriptfile, 'w') as script:
170 script.write("#!/bin/sh\n")
171 bb.data.emit_func("useradd_sysroot", script, d)
172 script.write("useradd_sysroot\n")
173 os.chmod(scriptfile, 0o755)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500174}
175
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500176do_prepare_recipe_sysroot[postfuncs] += "${SYSROOTFUNC}"
Patrick Williams213cb262021-08-07 19:21:33 -0500177SYSROOTFUNC:class-target = "useradd_sysroot_sstate"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600178SYSROOTFUNC = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500179
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500180SYSROOT_PREPROCESS_FUNCS += "${SYSROOTFUNC}"
181
Patrick Williams213cb262021-08-07 19:21:33 -0500182SSTATEPREINSTFUNCS:append:class-target = " useradd_sysroot_sstate"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600183
Patrick Williams169d7bc2024-01-05 11:33:25 -0600184USERADD_DEPENDS ??= ""
185DEPENDS += "${USERADD_DEPENDS}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186do_package_setscene[depends] += "${USERADDSETSCENEDEPS}"
187do_populate_sysroot_setscene[depends] += "${USERADDSETSCENEDEPS}"
Patrick Williams169d7bc2024-01-05 11:33:25 -0600188USERADDSETSCENEDEPS:class-target = "${MLPREFIX}base-passwd:do_populate_sysroot_setscene pseudo-native:do_populate_sysroot_setscene shadow-native:do_populate_sysroot_setscene ${MLPREFIX}shadow-sysroot:do_populate_sysroot_setscene ${@' '.join(['%s:do_populate_sysroot_setscene' % pkg for pkg in d.getVar("USERADD_DEPENDS").split()])}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600189USERADDSETSCENEDEPS = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190
191# Recipe parse-time sanity checks
192def update_useradd_after_parse(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500193 useradd_packages = d.getVar('USERADD_PACKAGES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500194
195 if not useradd_packages:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600196 bb.fatal("%s inherits useradd but doesn't set USERADD_PACKAGES" % d.getVar('FILE', False))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500197
198 for pkg in useradd_packages.split():
Patrick Williams213cb262021-08-07 19:21:33 -0500199 d.appendVarFlag("do_populate_sysroot", "vardeps", "USERADD_PARAM:%s GROUPADD_PARAM:%s GROUPMEMS_PARAM:%s" % (pkg, pkg, pkg))
200 if not d.getVar('USERADD_PARAM:%s' % pkg) and not d.getVar('GROUPADD_PARAM:%s' % pkg) and not d.getVar('GROUPMEMS_PARAM:%s' % pkg):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500201 bb.fatal("%s inherits useradd but doesn't set USERADD_PARAM, GROUPADD_PARAM or GROUPMEMS_PARAM for package %s" % (d.getVar('FILE', False), pkg))
202
203python __anonymous() {
204 if not bb.data.inherits_class('nativesdk', d) \
205 and not bb.data.inherits_class('native', d):
206 update_useradd_after_parse(d)
207}
208
209# Return a single [GROUP|USER]ADD_PARAM formatted string which includes the
210# [group|user]add parameters for all USERADD_PACKAGES in this recipe
211def get_all_cmd_params(d, cmd_type):
212 import string
213
Patrick Williams213cb262021-08-07 19:21:33 -0500214 param_type = cmd_type.upper() + "_PARAM:%s"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 params = []
216
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500217 useradd_packages = d.getVar('USERADD_PACKAGES') or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218 for pkg in useradd_packages.split():
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500219 param = d.getVar(param_type % pkg)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500220 if param:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600221 params.append(param.rstrip(" ;"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500222
223 return "; ".join(params)
224
225# Adds the preinst script into generated packages
Patrick Williams213cb262021-08-07 19:21:33 -0500226fakeroot python populate_packages:prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500227 def update_useradd_package(pkg):
228 bb.debug(1, 'adding user/group calls to preinst for %s' % pkg)
229
230 """
231 useradd preinst is appended here because pkg_preinst may be
232 required to execute on the target. Not doing so may cause
233 useradd preinst to be invoked twice, causing unwanted warnings.
234 """
Patrick Williams213cb262021-08-07 19:21:33 -0500235 preinst = d.getVar('pkg_preinst:%s' % pkg) or d.getVar('pkg_preinst')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500236 if not preinst:
237 preinst = '#!/bin/sh\n'
238 preinst += 'bbnote () {\n\techo "NOTE: $*"\n}\n'
239 preinst += 'bbwarn () {\n\techo "WARNING: $*"\n}\n'
240 preinst += 'bbfatal () {\n\techo "ERROR: $*"\n\texit 1\n}\n'
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500241 preinst += 'perform_groupadd () {\n%s}\n' % d.getVar('perform_groupadd')
242 preinst += 'perform_useradd () {\n%s}\n' % d.getVar('perform_useradd')
243 preinst += 'perform_groupmems () {\n%s}\n' % d.getVar('perform_groupmems')
244 preinst += d.getVar('useradd_preinst')
Andrew Geissler5199d832021-09-24 16:47:35 -0500245 # Expand out the *_PARAM variables to the package specific versions
246 for rep in ["GROUPADD_PARAM", "USERADD_PARAM", "GROUPMEMS_PARAM"]:
247 val = d.getVar(rep + ":" + pkg) or ""
248 preinst = preinst.replace("${" + rep + "}", val)
Patrick Williams213cb262021-08-07 19:21:33 -0500249 d.setVar('pkg_preinst:%s' % pkg, preinst)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500250
251 # RDEPENDS setup
Patrick Williams213cb262021-08-07 19:21:33 -0500252 rdepends = d.getVar("RDEPENDS:%s" % pkg) or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500253 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'base-passwd'
254 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'shadow'
255 # base-files is where the default /etc/skel is packaged
256 rdepends += ' ' + d.getVar('MLPREFIX', False) + 'base-files'
Patrick Williams213cb262021-08-07 19:21:33 -0500257 d.setVar("RDEPENDS:%s" % pkg, rdepends)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258
259 # Add the user/group preinstall scripts and RDEPENDS requirements
260 # to packages specified by USERADD_PACKAGES
261 if not bb.data.inherits_class('nativesdk', d) \
262 and not bb.data.inherits_class('native', d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500263 useradd_packages = d.getVar('USERADD_PACKAGES') or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500264 for pkg in useradd_packages.split():
265 update_useradd_package(pkg)
266}
267
268# Use the following to extend the useradd with custom functions
269USERADDEXTENSION ?= ""
270
271inherit ${USERADDEXTENSION}