blob: 9a8a09a9133ad260c755717f7a080ce9eaf7fae3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013
Brad Bishop757e94a2018-09-07 18:58:51 +000014SRCREV_FORMAT = "openocd"
Brad Bishopba6de432019-05-21 08:07:33 -040015SRCREV_openocd = "7ee618692f56b0efea864890da45d73d28e393d9"
Brad Bishop757e94a2018-09-07 18:58:51 +000016SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
17SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20PV = "0.10+gitr${SRCPV}"
21S = "${WORKDIR}/git"
22
23inherit pkgconfig autotools-brokensep gettext
24
25BBCLASSEXTEND += "nativesdk"
26
Brad Bishop757e94a2018-09-07 18:58:51 +000027EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028
29do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000030 ./bootstrap nosubmodule
Brad Bishop19323692019-04-05 15:28:33 -040031 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}/jimtcl/autosetup
32 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}/jimtcl/autosetup
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033 oe_runconf ${EXTRA_OECONF}
34}
35
36do_install() {
37 oe_runmake DESTDIR=${D} install
38 if [ -e "${D}${infodir}" ]; then
39 rm -Rf ${D}${infodir}
40 fi
41 if [ -e "${D}${mandir}" ]; then
42 rm -Rf ${D}${mandir}
43 fi
44 if [ -e "${D}${bindir}/.debug" ]; then
45 rm -Rf ${D}${bindir}/.debug
46 fi
47}
48
49FILES_${PN} = " \
50 ${datadir}/openocd/* \
51 ${bindir}/openocd \
52 "
53
54PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
55PACKAGECONFIG ??= "sysfsgpio"