blob: 56fe93a0bce85370aabc7788828adfaab82eb517 [file] [log] [blame]
William A. Kennington IIIb2c53062021-02-09 17:48:19 -08001LICENSE = "BSD"
William A. Kennington IIIe3f1bd82021-07-25 23:51:49 -07002LIC_FILES_CHKSUM = "file://COPYING;md5=667d4ad55f5fbf4c3e853e8acd0f74de"
William A. Kennington IIIb2c53062021-02-09 17:48:19 -08003
4PV = "0.1+git${SRCPV}"
Patrick Williamsbb99d222022-01-24 15:55:09 -06005SRC_URI = "git://github.com/yrutschle/conf2struct;branch=master;protocol=https"
William A. Kennington III32e3f012021-08-05 16:48:56 -07006SRCREV = "6bc9eed1eb50175e5fda791f27d85e72f5a6ac78"
William A. Kennington IIIb2c53062021-02-09 17:48:19 -08007S = "${WORKDIR}/git"
8
9SRC_URI += " \
10 file://0001-makefile-Add-missing-LDFLAGS.patch \
11 file://0001-conf2struct-Use-the-right-perl.patch \
12 "
13
14inherit native
15
16DEPENDS += " \
17 libconfig-native \
18 libconfig-perl-native \
19 "
20
21EXTRA_OEMAKE += " \
22 DESTDIR=${D} \
23 prefix=${prefix} \
24 "
25
26do_compile() {
27 oe_runmake checker
28}
29
30do_install() {
31 oe_runmake install
32}