blob: 5a8f21bd8c89ef8291f23a60251248897401c272 [file] [log] [blame]
Patrick Venture9afb6712018-09-17 17:14:46 -07001SUMMARY = "Google Sys OEM commands"
Patrick Ventureedb61922018-09-21 14:57:58 -07002DESCRIPTION = "Google Sys OEM commands"
Patrick Venture3adb97a2018-09-26 08:42:56 -07003HOMEPAGE = "https://github.com/openbmc/google-ipmi-sys"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture9afb6712018-09-17 17:14:46 -07008
Andrew Geisslerf64c3c02021-06-24 11:00:17 +00009inherit meson pkgconfig systemd
Patrick Venture9afb6712018-09-17 17:14:46 -070010
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000011DEPENDS += " \
12 nlohmann-json \
13 phosphor-dbus-interfaces \
14 phosphor-logging \
15 phosphor-ipmi-host \
16 sdbusplus \
17 systemd \
18 "
Patrick Venture9afb6712018-09-17 17:14:46 -070019
Patrick Venture9afb6712018-09-17 17:14:46 -070020S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060021SRC_URI = "git://github.com/openbmc/google-ipmi-sys;branch=master;protocol=https"
Andrew Geissler297f9832021-11-11 17:30:13 +000022SRCREV = "40fe52225515f6ec82858795638add0b4c8e94af"
Patrick Venture9afb6712018-09-17 17:14:46 -070023
Willy Tu4dd03ca2021-08-06 09:37:35 -070024FILES:${PN} += "${libdir}/ipmid-providers"
Patrick Venture9afb6712018-09-17 17:14:46 -070025
26SYSTEMD_PACKAGES = "${PN}"
Willy Tu4dd03ca2021-08-06 09:37:35 -070027SYSTEMD_SERVICE:${PN} += " \
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000028 gbmc-host-poweroff.target \
29 gbmc-psu-hardreset.target \
30 "
Patrick Venture9afb6712018-09-17 17:14:46 -070031
Andrew Geisslerf64c3c02021-06-24 11:00:17 +000032EXTRA_OEMESON += "-Dtests=disabled"
William A. Kennington IIIa4cdbe62021-06-04 18:13:35 -070033
Willy Tu4dd03ca2021-08-06 09:37:35 -070034CXXFLAGS:append:gbmc = '${@"" if not d.getVar("GBMC_NCSI_IF_NAME") else \
William A. Kennington III577d20f2021-02-17 14:33:38 -080035 " -DNCSI_IPMI_CHANNEL=1 -DNCSI_IF_NAME=" + d.getVar("GBMC_NCSI_IF_NAME")}'