blob: 7ede35412342d24a04d601b84fd55035a04227fd [file] [log] [blame]
Patrick Williams12fc9392021-08-06 09:16:53 -05001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Ed Tanousd9aea6f2019-01-11 16:26:13 -08002
3DEPENDS += "systemd"
4
Patrick Williamsbb99d222022-01-24 15:55:09 -06005SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
Vernon Mauerye0b32cb2020-03-04 11:02:02 -08006SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
Vernon Mauery5896a232019-04-23 15:31:51 -07007
Vernon Mauerye0b32cb2020-03-04 11:02:02 -08008# TODO: when a new company joins the OpenBMC project by signing
9# a CLA, if they have an enterprise number on file with the
10# IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
11# needs to be updated to add their entry. The canonical
12# version of the file is locatede here:
13# https://www.iana.org/assignments/enterprise-numbers
14#
15# This file is manually downloaded so it can be versioned
16# instead of having the makefile download it during do_compile
Vernon Mauery5896a232019-04-23 15:31:51 -070017SRC_URI += " \
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080018 file://enterprise-numbers \
Vernon Mauery5896a232019-04-23 15:31:51 -070019 "
20
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080021# make sure that the enterprise-numbers file gets installed in the root FS
Patrick Williams12fc9392021-08-06 09:16:53 -050022FILES:${PN} += "/usr/share/misc/enterprise-numbers"
23do_compile:prepend() {
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080024 # copy the SRC_URI version of enterprise-numbers
25 # to the build dir to prevent a fetch
James Feist19841272020-05-01 14:35:25 -070026 mkdir -p "${WORKDIR}/build"
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080027 cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
28}
29
Vernon Mauery5896a232019-04-23 15:31:51 -070030S = "${WORKDIR}/git"
31LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
32
Patrick Williams12fc9392021-08-06 09:16:53 -050033EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
Vernon Mauery5896a232019-04-23 15:31:51 -070034
35PV = "1.8.18+git${SRCPV}"