blob: 99a80bc41c8ac8863d284d1e1a25d5c9808c8526 [file] [log] [blame]
Patrick Venturec57ab162018-09-22 18:56:00 -07001SUMMARY = "Phosphor OEM IPMI Ethernet Stats Implementation"
2DESCRIPTION = "This package handles receiving OEM IPMI commands to provide ethernet device statistics."
3HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-ethstats"
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
14
15S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060016SRC_URI = "git://github.com/openbmc/phosphor-ipmi-ethstats;branch=master;protocol=https"
Andrew Geissler19908532021-11-02 08:30:53 +000017SRCREV = "c8894c55f5d58862f266aebedc43e2652f529a41"
Patrick Venturec57ab162018-09-22 18:56:00 -070018
Patrick Williams12fc9392021-08-06 09:16:53 -050019FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
20FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
21FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
22FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venturec57ab162018-09-22 18:56:00 -070023
24HOSTIPMI_PROVIDER_LIBRARY += "libethstatscmd.so"
William A. Kennington IIIccde0202021-06-04 17:45:28 -070025
26EXTRA_OECONF += "--disable-tests"