Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "GNOME XSLT library" |
| 2 | DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \ |
| 3 | XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \ |
| 4 | libxml2 the XML C library developed for the GNOME project. It also implements most of \ |
| 5 | the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \ |
| 6 | and expressions extensions." |
| 7 | HOMEPAGE = "http://xmlsoft.org/XSLT/" |
| 8 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458" |
| 12 | |
| 13 | SECTION = "libs" |
| 14 | DEPENDS = "libxml2" |
| 15 | |
| 16 | SRC_URI = "https://download.gnome.org/sources/libxslt/1.1/libxslt-${PV}.tar.xz" |
| 17 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "3a4b27dc8027ccd6146725950336f1ec520928f320f144eb5fa7990ae6123ab4" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 19 | |
| 20 | UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar" |
| 21 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 22 | # We have libxml2 2.9.14 and we don't link statically with it anyway |
| 23 | # so this isn't an issue. |
| 24 | CVE_CHECK_IGNORE += "CVE-2022-29824" |
| 25 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 26 | S = "${WORKDIR}/libxslt-${PV}" |
| 27 | |
| 28 | BINCONFIG = "${bindir}/xslt-config" |
| 29 | |
| 30 | inherit autotools pkgconfig binconfig-disabled lib_package multilib_header |
| 31 | |
| 32 | do_configure:prepend () { |
| 33 | # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header. |
| 34 | # This can be removed when upgrading to 1.1.34. |
| 35 | sed -i -e 's/ansidecl.h//' ${S}/configure.ac |
| 36 | |
| 37 | # The timestamps in the 1.1.28 tarball are messed up causing this file to |
| 38 | # appear out of date. Touch it so that we don't try to regenerate it. |
| 39 | touch ${S}/doc/xsltproc.1 |
| 40 | } |
| 41 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 42 | EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 43 | # older versions of this recipe had ${PN}-utils |
| 44 | RPROVIDES:${PN}-bin += "${PN}-utils" |
| 45 | RCONFLICTS:${PN}-bin += "${PN}-utils" |
| 46 | RREPLACES:${PN}-bin += "${PN}-utils" |
| 47 | |
| 48 | # This is only needed until libxml can load the relocated catalog itself |
| 49 | do_install:append:class-native () { |
| 50 | create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog |
| 51 | } |
| 52 | |
| 53 | do_install:append () { |
| 54 | oe_multilib_header libxslt/xsltconfig.h |
| 55 | } |
| 56 | |
| 57 | FILES:${PN} += "${libdir}/libxslt-plugins" |
| 58 | FILES:${PN}-dev += "${libdir}/xsltConf.sh" |
| 59 | |
| 60 | BBCLASSEXTEND = "native nativesdk" |