blob: 82adcdeca17e437a5947c0aeec5654bef7a36b5a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
8 file://0001-cmake-Link-utils-with-xcb-explicitly.patch \
9 file://0001-cmake-Link-test-utils-with-ldl.patch \
10 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Patrick Williamsc0f7c042017-02-23 20:41:17 -060012# From 2016-07-07
13SRCREV = "c39e41a86551eb390b8da23232dc8577639403d0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014# (when PV goes above 1.0 remove the trailing r)
15PV = "1.0+gitr${SRCPV}"
16
17S = "${WORKDIR}/git"
18
Patrick Williamsc0f7c042017-02-23 20:41:17 -060019DEPENDS = "libpng virtual/libx11 libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021inherit cmake python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022# depends on virtual/libx11
23REQUIRED_DISTRO_FEATURES = "x11"
24
Patrick Williamsf1e5d692016-03-30 15:21:19 -050025# The built scripts go into the temporary directory according to tempfile
26# (typically /tmp) which can race if multiple builds happen on the same machine,
27# so tell it to use a directory in ${B} to avoid overwriting.
28export TEMP = "${B}/temp/"
29do_compile[dirs] =+ "${B}/temp/"
30
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031PACKAGECONFIG ??= ""
32PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
33
34do_configure_prepend() {
35 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
36 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
37 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
38 fi
39}
40
Patrick Williamsc0f7c042017-02-23 20:41:17 -060041do_install() {
42 oe_runmake -C ${B} 'DESTDIR=${D}' install/strip
43}
44
45RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
46 python3-subprocess python3-misc python3-importlib \
47 python3-unixadmin python3-xml python3-multiprocessing \
48 python3-six python3-shell python3-io python3-argparse \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049 mesa-demos bash \
50 "
51
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052INSANE_SKIP_${PN} += "dev-so already-stripped"