blob: 98c55dca85794e4988b518beb8d7934c661b5acc [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
Brad Bishop19323692019-04-05 15:28:33 -04006 file://0001-Add-crc32.c-to-sources-list.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -05007 file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008 "
9
Andrew Geisslerc182c622020-05-15 14:13:32 -050010SRCREV = "b213f749405d84e989b25e183bcf28ce701696dd"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011
12S = "${WORKDIR}/git"
13
14inherit cmake distutils3-base
15
16DEPENDS += "libxml2 expat libcheck"
17
18EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
19OECMAKE_SOURCEPATH = "${S}/libcomps"
20
21BBCLASSEXTEND = "native nativesdk"
22