blob: dadde0b2a0033a92fa47186fb46c4b2688d3737b [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "A portable foreign function interface library"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://sourceware.org/libffi/"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05003DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b"
12
Brad Bishopc68388fc2019-08-26 01:33:31 -040013SRC_URI = "https://github.com/libffi/libffi/releases/download/v3.3-rc0/libffi-3.3-rc0.tar.gz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014 file://not-win32.patch \
Brad Bishopf3fd2882019-06-21 08:06:37 -040015 "
Brad Bishopc68388fc2019-08-26 01:33:31 -040016SRC_URI[md5sum] = "8d2a82a78faf10a5e53c27d986e8f04e"
17SRC_URI[sha256sum] = "403d67aabf1c05157855ea2b1d9950263fb6316536c8c333f5b9ab1eb2f20ecf"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018
19EXTRA_OECONF += "--disable-builddir"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
Brad Bishopc68388fc2019-08-26 01:33:31 -040021inherit autotools texinfo multilib_header
22
23S = "${WORKDIR}/${BPN}-3.3-rc0"
24
25do_install_append() {
26 oe_multilib_header ffi.h
27}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028
29FILES_${PN}-dev += "${libdir}/libffi-${PV}"
30
Patrick Williamsc0f7c042017-02-23 20:41:17 -060031# Doesn't compile in MIPS16e mode due to use of hand-written
32# assembly
33MIPS_INSTRUCTION_SET = "mips"
34
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050035BBCLASSEXTEND = "native nativesdk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050036