blob: 39c478a954c135c5dfcf731131f92bce05b9162d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Inspect and manipulate eBPF programs and maps"
2DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \
3of eBPF programs and maps."
4LICENSE = "GPLv2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS = "binutils elfutils"
6PROVIDES = "virtual/bpftool"
7
8inherit bash-completion kernelsrc kernel-arch
9
10do_populate_lic[depends] += "virtual/kernel:do_patch"
11
12EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
13
14do_configure[depends] += "virtual/kernel:do_shared_workdir"
15
Andrew Geissler1548c072019-02-22 16:03:50 -060016COMPATIBLE_HOST_libc-musl = 'null'
17
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018do_compile() {
19 oe_runmake
20}
21
22do_install() {
23 oe_runmake DESTDIR=${D} install
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28python do_package_prepend() {
Brad Bishop19323692019-04-05 15:28:33 -040029 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030}
31
32B = "${WORKDIR}/${BPN}-${PV}"